No input/output audio repsonse in Cubase

Alright, I got a new computer: WIndows 7, 64 bit, i7, 8GB RAM. i installed Cubase 5, and I have a Tascam US-122L USB interface. Yesterday I recorded and everything worked fine, today, nothing.

I have the Tascam set as the input and output ports in Cubase, they are active and have respective buses active. I am using the Full Duplex driver. I can see audio response on the Tascam interface and I can hear it through the headphone jack in the interface, however, there is no repsonse in Cubase. the Level Meters don’t move, there’s no waveform when I record, nothing.

What I did notice is this: i have another computer running Windows XP, and it has Cubase LE 4 installed on it. Just to test, I hooked up the interface and recored, it works fine. However, in the device setup control panel, the interface for input and output is titled “Tascam-US-122L” and on my new computer they are listed as “Line-in-Tascam” and “Speakers-Tascam” for input and output respectively. I’ve tried every input and output port on the interface and i can’t get any sound out of it through Cubase.

I’m stumped. Help?

As explained in the manual: Use the correct driver…

That was simple enough.