No Input signal/playback after Mac Sierra OS install

Running elements 7 with a Tascam US 16X08 interface.
(I’ve included screen grabs for everything i’m about to outline)

So last night I decided to update the OS on my Mac to the latest version. Before the update cubase worked perfectly fine.

Now when I open Cubase and set up my projects as usual with my interface there’s no input signal at all.

I know it’s definitely not the interface because I can see in the digital mixer that there’s signal coming from the input.
Screen Shot 2017-03-11 at 11.45.11 pm.jpg
I’ve mapped everything properly and am using the correct and latest driver for my interface.
Screen Shot 2017-03-11 at 11.42.54 pm.jpg
Screen Shot 2017-03-11 at 11.41.36 pm.jpg

I’ve tried running the software in both 64 bit and 32 bit.

I’ve tried setting the Mac’s sound to the Tascam for input and output
Screen Shot 2017-03-11 at 11.41.36 pm.jpg
Is this just a bug with Sierra? I got so frustrated I downloaded Reaper and everything works fine in there.

Should i just wait it out for an update? Anyone else experiencing the same problem after updating to Sierra OS?

Any and all help would be greatly appreciated.

Cheers!

Did you ever get a solution to this problem?