No midi output in Cubase vst5

hi,
up until last night everything worked fine.
Today,working on the same project i still have no midi output,no green flashing light on transport,only red midi input.
Midi Thru is enabled so its not that.
i can programme in midi notes and hear them on playback,just cant trigger them from my midi keyboard.
i even tried reinstalling my DMX soundcard,made no difference,still no output from hitting keyboard.
Anyone got any ideas on how i can fix this please?
Just hope someone looks in this old corner of the forum,doesnt seem to get many visits.
Anyway,heres hoping there is someone who can help me out on this.
cheers
j.

Trash Prefs.

thanks for the reply,never ‘trashed prefs’ ,how do i do it please?

btw why does everytime i try to view a thread or post a reply i have to login again,again and again?

Knowledge Base article with how-to’s.

went to knowledge base,was unable to find anything on ‘How to remove preferences’ for cubase vst.
Do you have a link please?

found it,will post results.

not sure if the results seem to apply to cubase vst5.1-the articles seem to mention nuendo as well which i dont have,not sure what release of cubase they are talking about but it isnt vst(the last one before they released sx).
typed in my correct edition of cubase but just get articles mentioning nuendo in the search results.
STUMPED!

Did you find the Steinberg App Data folder?

sorry,have found it,removed preferences file from folder to empty folder on desktop,
Still no midi sound when triggering from keyboard.
Have just tried Reason on its own instead of usually rewiring alongside cubase,no midi output from that either.
So it looks like something wrong with either midi in the soundcard,cables,keyboard or M-audio midisport x2 interface.
Going to start checking cables first.
thanks for the help,much appreciated.

If you want to do a team viewer session to try to sort it, let me know.

Not being a regular here i dont know what you mean by team viewer session,but any kind of help is appreciated,so yes.
i disconnected the midi chain and just tried midi keyboard into the DMX midi in(with different midi cables) and tried to trigger a vsti but still no output that way,only way is by drawing in midi notes which i can hear on playback.
thanks for helping out NWP.

Team Viewer is an app that lets us share screens. Nothing to install, you just run it and send me the log-on creds via PM.

http://www.teamviewer.com/en/index.aspx?pid=google.tv.s.us&gclid=CInb4MK_q7oCFYqi4Aodt10AqQ

will have to unattach everything and bring the pc into front room,its not attached to the net at the mo,i just use it for music production,use another pc(one i am on now)to browse the net.let me know when you want to do it,probably best time is after 6pm ish if thats a good time for you?

and you’ll need to talk me through what to do,not sure what you mean by log on creds?

I’m on EST time, how about you? The log-on creds will appear when you run TV. Easy as pie. PM me to work out the time details.

hi guys
sorry about the delay getting back to you.
just started backing up my cubase songs files and audio folders and some plugins that didn’t come with installers before i reinstall it.
Also,backing up Reason songs cos i am going to reinstall that as well.
Just need a little help in setting up my midi chain again as i forgot how it was before i disconnected it all.
The chain has,midi keyboard(1 out),DMX6 soundcard (in/out)phatboy midi controller (in/out)Korg ER-1(in/out/thru),midisport usb midi interfacex2(in/out).The kaos pad has midi in/out but i don’t bother hooking that up in the midi chain,i just record its audio direct into the dmx6 soundcard.
I only started using cubase vst 5.1 again after a longtime away from it,that’s why i am a bit ignorant on the midi chain side of things.
What does the last update 5.2 add to 5.1?
One thing i was noticing just before the midi output went pear shaped was that it wasnt recording midi cc changes,such as a basic filter sweep,nothing was being filtered out in cubase so don’t know why it wasn’t recording cc 's,also,i tried to draw in a filter sweep in the controller editor and using the pencil or line tool it would not draw in anything,tried it using both tools with alt held down still nothing.
Also,why doesnt the midi interface of the midisport show in midi devices in Reason?i always get the 'cant open midi as its being used by another device
Any input always appreciated.
Hopefully have this sorted soon i hope.
thanks folks.

Reinstalled cubase vst 5.1 and also Reason 2.5.
Reason now sees usb midisport midi ins/outs.
Still no response from midi keyboard,can draw in notes and they playback whichever vsti or reason instrument i have midi channel routed to.
Can also now draw in midi cc like pitchbend which before reinstall i couldn’t.
One strange thing i noticed,when i opened cubase and was working in the .def file which opens as default ,i opened the JX16 vsti that came with cubase vst,made a midi part 4 bars long,didnt draw in any notes,but,when i playback cubase triggers sounds by itself,usually 2 different notes.
This only happens in the .def project file,any other projects it doesn’t do it,never seen it do that before,it seems to do it with whatever vsti i choose,i was using midi channel 1 output to the vsti.
One thing that does seem to have been fixed is an annoying popping type sound coming from my speakers.

I thought it was something to do with my old amp or speakers but after reinstalling cubase it has dissapeared.
Cubase still triggers the Korg ER-1 drum machine to play alongside in sync so midi is being sent in there.
So,the only problem is,no midi sound when i try to play from the midi keyboard.
Read manual and the .pdf manuals and cant see whats wrong.

In the Asio Direct sound setup where it says ‘sync Reference’,i have the option ‘direct sound output’ ticked not ‘direct sound input’,is that right?In card options i have ‘Full Duplex’ ticked rather than ‘start input first’,is that the right option to have ticked?

I am stumped at the mo,i’ll keep looking at the ‘Getting into Details’ .pdf manual and see if i can get the answer from that.i will have a good look at midi filtering’ & ‘midi transformer’,i’m not filtering anything out except the default systex,not had much time last few days but tonight will look into the ‘midi transformer’ and see if theres something in there causing this problem,fast thinking i am going to try and buy a secndhand legit copy of sx on ebay,a version that my AMD 1.91 will be able to handle.
Meantime,back to the drawing board or .pdf in this case.

yes its standard midi cable,into my dmx midi in.
Just before reading this i was thinking,do i need the midisportx2 usb interface now i sold on my old Astation synth?i needed it when i had the synth,which was in the chain with phatboy controller and drum machine.
When using cubase i have the midi channel out routed to either a vsti,reason or my er1 drum machine,not sure what you mean by having all midi inputs selected,do you mean on the main sequencer interface or in cubase options/midi system?
in a bit of a rush at the mo but when i get back later i am going to see if i can hook the midi up together without the midisport usb interface,i have the midi out of the drum machine to the midisports in(i think,will look later tonight when i get back in) but dont have any midi out cables from the midisport ,the drum machine is running in sync with cubase and i can programme in midi notes to trigger say a kick which i often do to beef up some drum sounds usually coming from a reason module.
thanks for the input,again its always appreciated.will speak later.

I tried without the midisport connected,still unable to trigger from my midi keyboard,
This is how midi system in options looks-
Midi input-DMX 6 Fire MIDI
Mapped to- DMX 6 Fire MIDI

Midi output-Microsoft GS Wavetable
Mapped to-Microsoft GS Wavetable

Midi Input from
DMX 6 Fire MIDI
DMX 6 Fire Wavetable
in-A usb midisportx2
in-B usb midisportx2
MROS

i have all all of these ‘inputs from’ ticked

thats the way i have always had it setup and it worked until a week or so ago.

i think when i first got Cubase i got a lot of help learning how to set it up and use it from online forums,tutorials,computermusic magazine articles etc,i’m still pretty ignorant after all these years because its always worked and i have never had major problems like this.I also spent a few years when i wasnt using it so forgot a lot of stuff.
Apart from the odd crash it was working as it should.
I have noticed after formatting my HD a while back i now get this error message after downloading a lot of windows updates,i didnt have it connected to the web until recently,i’d followed tips on tweaking xp so using the net was a no go area.message says - “C;\Documents and settings\john g\Application Data\Babsolution\enhancedNT.dll,Run”.
Could this have something to do with the problem somehow?saying that,cubase still worked fine when getting that after windows starting?

At least i am able to programme notes in and hear midi and audio,even after reading the manual relearned how to setup the midi mixer module so it now has some basic effects on the channel with midi parts on,one thing though,it no longer plays the GM sounds after loading the patch-name script,tried it earlier,drew in some notes hit play but couldn’t hear anything though the midi mixer shows volume level activity.
So the mystery remains,i will download the update to 5.2,is it still a Beta?
See what happens with that.Until then i’ll put up with it,try if i can see anything in the .pdf manual and hard copy that came with it for a week or so then i’m going to try a system restore back to its original working state it came as from INTA Audio.
I don’t think i’ve anything to lose doing that,it’ll just be another time consuming attempt to get my midi working as it should.
Anyone who has anymore suggestions please let us hear them.
cheers folks.

yes,did all of those,still no sounds from GM voices from loading patchname script.green output on transport bar,volume levels activity in midi channel strip but just no sound.
thanks for the input steve.