no midi

hey,

for some unknown reason, ive lost the ability to record midi from my keyboard. everything is connected but no sound is reaching Cubase. though when I open a midi track with halion I have sound when i click on the virtual keyboard

any ideas as to why or how to resolve?

Since recently you now have to click the monitor button on midi tracks, as you always have had to for audio, to get a signal through. Could this be the problem?

i did that and still Nothing. though up untill today ive never done that either and im using elements 8.

Cables? And that’s me out of ideas…

A couple of thoughts…

  • Plug in your usb device befor starting Cubase.
  • Possible usb port failure. Try another.

Regards. :sunglasses:

thanks both my cables work fine and i shall look into the USB port. my device is allways plugged in before opening cubase. M-audio midi sport uno is the device

so infact it was the USB port that was the problem. i switched it and works fine though indeed now i must use the monitor button to hear it.

once again, im suffering with this midi problem
been working fine now since this last post (3 months approx) and suddenly ive got no sound / signal coming in from keyboard.
my midi device is all there in cubase everything is active but no sound
midi.png

Tough to tell by the pic… did you assign a sound?

Also, is your keyboard local function set to off?

Did you try another different USB port?

Regards :sunglasses:

Thx for thé reply and yes to all. All was working, i left my computer for 1hoùr (with cubase open) came back to no midi

Sometimes USB ports are set to go to sleep after a hour (or whatever time) with no activity. Check that, and disable the sleep function. Not sure what version your operating system is but there settings are in the power saving section.

Regards :sunglasses:

i will have a look at that. although the lights on the midisport UNO are lit up so that tells me that power is coming frum USB.
aswell im on Windows 7 ultimate x64


thx

Are you using a USB hub by any chance?

Have you tried ‘Midi-ox’ to see if midi data is actually coming into windows when this issue occurs? If not it could be a problem with the usb port or connectivity or your Roland E-09? Also, try to use only backpanel usb ports (directly connected to your main board). Try avoid front panel ports.

Well i have midi in back though i dont hear anything when i play the keys. I have midi playback though.

When you play your keyboard do you see the keys on Halion Sonic plugin move? And is this issue in all plugins. Have you tried adding another instrument track with another plugin? Have you tried different sample rates (44-48-96_ in project setup?

hi,

no keys are moving in halion sonic when i play, though i can record midi when i play. i have not tried in other vst yet. or sample rates, i will check that next time

Hello,

Does the midi indicator in Halion Sonic flash red (It on the upper left in Halion Sonic) when playing on your keyboard?
Can you show us the Midi Routing in the inspector for the instrument track you want to play.?

Is midi thru activated in the preferences of cubase?