No notes off when stopping playback in Dorico 4.2 (related to new WinRT MIDI setting)


I’ve just updated my 4.1.10 version to 4.2 and when I want to stop the playback on Dorico side, the notes on my VSL VEP 7 keep playing last chord until I stop it manually.
I use exclusively MIDI instruments no VST.
I uninstalled 4.2 and reinstall 4.1 and playback/stop worked fine again.
Is anybody else facing this situation ?
Or do you have any idea what happened ?

Thanks for advise.
Best regards.

Have you perhaps turned off Reset controllers and send ‘all notes off’ when stopping playback on the Play page of Preferences?

Hello Daniel,
Thank you for your message.
And yes, it is the first thing I checked and it is ticked.

If you’re on Windows, try switching off the new option for WinRT MIDI:

You were right (as usual ;-)).

I cross read the version history without making the link with WinRT MIDI change.
Thank you for your quick, efficient and kind support.

Best regards.

This was working prior to 4.2 update. I have tried unchecking and checking the ‘Reset controllers and send ‘all notes off’ when stopping playback’ checkbox in the Play section of Preferences, saving and restarting Dorico after each.

See here:

Thanks. I did as you suggested and rebooted just to be sure. Now I have no midi output from Dorico at all. I have the same setup as ivanduch in the referenced ticket. Windows10/Dorico/loopMidi/Reaper. Also noticed that all midi input devices were checked. Unchecked them all and rebooted. All expression maps have been reset to Default. Very frustrating.

I’ve merged this thread with another identical one from just a couple of hours ago. (Please do try to search before you start a new thread – not only does it save duplicate posts, but chances are you’ll find the solution you’re looking for right away.)

You really should find that switching off the Enable WinRT MIDI option in the Advanced Options section of the Play page of Preferences is sufficient to solve this problem, provided you quit and restart Dorico after having switched it off. Please do Help > Create Diagnostic Report and attach the resulting zip file here so we can take a closer look at your configuration.

1 Like

Thanks, Daniel. I did do a cursory search but didn’t see anything. Uploaded file.
Dorico (872.5 KB)

The WinRT option was indeed set until the most recent run of the application, but it does appear to be disabled now. Everything else looks OK to me, though I’m not the most expert at reading the runes of these log files, particularly for the audio engine.

If you start a simple new project and play it back using Dorico’s own default playback template, does that behave properly?

Ok. It’s working now. Something odd was going on with the midi instruments in play mode. There were some instruments in the dropdown with numbers in square brackets after the name i.e. loopMIDI 1 [1]. Those are gone now. No idea what was up with that. Thanks for you help.

It sounds as if the names of the virtual MIDI devices you have on your system are perhaps different when using the new WinRT MIDI APIs, possibly resulting in some ports you are using as outputs ending up enabled as inputs that Dorico doesn’t know should be disabled, thus resulting in a MIDI feedback loop.