No playback at all

I had really hoped to solve this on my own, or by looking in existing topics, but I guess I need to ask:

I am not getting any sound in Play Mode. As there is no section for this in the online help, and the tutorial video moves through this pretty fast, I’m not even sure what is supposed to happen.

What happens for me is this: I have a very short (2 measures) simple orchestral score for tryout purposes. When I go to Play Mode, I see a beautiful graphic representation of my instruments and score, multicolored on a gray background, plus some control icons at the upper right. If I click the green Play triangle, literally nothing happens. If I open the Transport Bar and do the same thing, I do see the numbers zip by, but still no sound.

My VST Instruments panel says HALion Sonic SE.

In Preferences, Audio Device Setup says Built-In Audio (and the pulldown offers no other option), Device Control Panel… if clicked opens a HALion Sonic SE mixer board with lots of controls (but producing no sound).

I do have the VSTAudioEngine folder (13 items), in ~/Library/Preferences. My laptop audio is on, and I hear sound from all other applications.

I suspect I’ll embarrass myself by having overlooked something obvious, but after fiddling with this for a day, I figured it was time to ask.


Do you get any sound if you bring up the HALion plug-in UI, drag up the modulation wheel (the second one from the bottom left-hand corner) and then click on the keyboard in HALion’s window? If you do, then at least audio is getting all the way through the system. If not, then that is probably the starting point for diagnosing the problem.

No, no sound when I did that. (If I was doing it right – my cursor has to let go of the wheel to click on a key, so it returns to its lower position before I can click.)

Do you have any joy if you click the Device Control Panel setting in the Edit > Device Setup dialog, and fiddle with the various options in there?

I’m afraid it’s 3am here and I’m really long overdue being in bed, so I’m going to have to bow out of this thread for now, but I’ll look in on it again tomorrow.

Thanks, Daniel. I quite understand. I was amazed you were out and about at all tonight, so I wanted to make the most of it. Please go and get some well-earned rest, and we’ll carry on tomorrow. I’m having plenty of fun here playing with my new toy. Playback can wait.

(I don’t change anything by fiddling with that setup panel; it’s the same one I saw in Preferences, and doesn’t really offer me any alternatives. But it was a good thought.)

Does the HALion VU meter show movement when you click on a key at the bottom of the HALion screen?

Hi Rinaldo,
please do something more simple and easy: Create a new project and add just a Piano player. Then in write mode, double click the stave and enter some arbitrary notes. Then click the play button, and some sound should come out.
This Piano example doesn’t have all this issue with modulation wheels and the like and the sound should come out straight away. If it doesn’t, then please open the HALion Sonic SE editor window (in Play Mode, click on the ‘e’ button left to HALion Sonic SE.) Then, play with the mouse on the virtual keyboard. Does sound come out? Does in the HALion window some VU meter show up while playing with the mouse.

Aha. Well, here’s a new development: I now get nothing at all (no HALion window) when I click Device Control Panel. I was seeing it before, but for some reason not now.

(I did change from HALion Sonic SE to Symphonic Orchestra and back, to see if that would reset something, or reload something, or I don’t know what. It’s back on HALion now.) So… I’m in your hands for the next step.

Trying to think what to try next:

Is it ever wise to re-download Dorico? (In case I’m missing something.) If that’s feasible, does one need to uninstall first?

Ulf is on holiday this week, but I expect he will check in again soon (he also doesn’t work at the weekends, but that didn’t stop him popping up over the weekend either). I don’t think reinstalling Dorico will make any difference, I’m sorry to say.

You shouldn’t get a HALion window when clicking the Device Control Panel button in Device Setup: rather you should see a window with Core Audio Device Settings as its title. Make sure that the ‘Built-in output’ option is checked in there, assuming you’re expecting to hear sound come out of your Mac’s speakers or headphone jack.

“Built-In Audio” appears on the Device Setup window next to “Asio Driver”. It isn’t actually checked, but there’s no other option there (if I try to pull down the menu there, that’s all there is). And the “Device Control Panel…” button definitely used to give me the HALion window with all the wheels and dials and keyboard. Now it does nothing (except blink) when I click it.

So when you click Device Control Panel, you don’t get a window that says Core Audio Device Settings? That in itself is very suspicious, but unfortunately I don’t know what the next troubleshooting step will be. I’ll drop Ulf a line on the off-chance he will pick it up.

Correct. The button blinks, but nothing further happens. (Formerly, I would see the HALion window when I clicked there. I don’t know exactly when this changed.)

Thank you for your help with this, Daniel. Ulf already responded here a couple of times, very helpfully if only I were able to do what he suggests. I’ll be patient if this is his week off. I have plenty of tests to give and grade, and papers to advise on, and otherwise keep busy with the work I’m supposed to be doing.

Hi Rinaldo,
I also first thought, it’s not possible what you are saying, namely that the HALion window opens when you click on Device Control Panel. Then thinking again, yes, it is, but not exactly like that.
Well, it is like this. Dorico and the audio engine run as different processes (for reasons I don’t want to explain here) and the audio engine runs headless, that means has itself no GUI or menu. When you click on Core Audio Device Settings, then the audio engine gets “activated” and all windows of the audio engine will come to front. In this case, HALion runs within the audio engine and so the HALion window is - so to speak - owned by the audio engine. So when clicking on Device Control Panel, the HALion window is not newly opened, it is just in the background behind the Dorico window, and it then just gets pushed to the front, that is all. If no HALion window was already opened in the background, then the Device Control Panel would not open a new HALion window.
But actually what you would expect to see is the Core Audio Device Setting window. Now, this is the mystery. Why does that window does not get opened (as it normally should)? Maybe it does, but it just stays behind the Dorico window. Could you please check by minimizing or dragging the Dorico window to the side?
If it is not, you could open the Core Audio Device Setting via the System Preferences. I don’t have a Mac right now at my fingertips, so I don’t know exactly what to look out for. I think it is ‘Sound’ or ‘Audio Setup’. Please check yourself. In that Core Audio Device Setting make sure that really the Built-in output device is ticked. And also make sure that the volume is pumped up.
And also please do the test again as I described earlier: create a Piano project with a few notes…press playback and see what the HALion window shows. Is some MIDI activity and VU metering visible? If it is, then we know that the problem is really on the last mile, namely between the audio engine’s output and the speakers.

Well, as I said in a later response above, it no longer does. I now cannot see the HALion window at all, no matter what I do. I don’t know when or why this changed

I did this – I closed or minimized all other windows of all applications, getting right down to the desktop. No Core Audio Device Setting window is visible anywhere.

I opened System Preferences and selected Sound. The only Output option shown is “Internal Speakers.” I see no mention of Core Audio Device Setting.

I would gladly do this, but as noted, since I first asked this question two days ago, something has changed and I can no longer make the HALion window appear. Is there a way I can make it open from outside Dorico?

Thank you for all your advice and attention.

Not from outside of Dorico, but from inside Dorico. Once you created your Piano project, go to Play Mode. There on the right side you see the VST Instrument rack where already on HALion Sonic SE instrument shall be listed. Can you see that, or is the instrument rack just empty?
If HALion Sonic SE is there, have a look directly left of it, you’ll see a button with an ‘e’ on (looks bit funny, but it shall depict an ‘e’.) Click on that button (maybe twice) and the HALion editor window will open.

Yes, yes, yes! Not only did pressing that “e” bring up the HALion window, but now I am hearing sounds! And now when I click on Device Control Panel, it does what you and Daniel said it should – it shows me the window Core Audio Device Settings, which I’ve never seen before.

I am hearing sound in all my other (small) projects too.

One problem, perhaps related to the difficulty with starting this in the first place: the proper instruments are not loaded here. In slot #1 is always First Contact, a sliding theremin-like timbre, and nothing in any of the others. In the one score that was just piano, I was able to find an Acoustic Piano instrument and load that, and the score now sounds as it should. But for a full orchestra score this will get laborious; is there a way to automate the process?

(Also, when I closed that window, puttered around a while, and came back, all my instrument assignments in the HALion window were gone, and I had to do them again. This also happens if I move between different projects, or if I quit and re-open, even if I have saved. No instrumental assignments in HALion are remembered, it’s always that First Contact.)

Thank you so very much, Ulf. I don’t know what changed, but it’s a thrill to hear things working now. I’m excited!

Hi Rinaldo,
glad to hear that you do now get sound out.
It’s still a mystery though, why always only that ‘First Contact’ sound gets loaded.
You can rectify this by going to the Play Mode and then from the menu choose Play > Apply Default Playback Template.
If you do that, then save the project, close and reopen it, then also the instrument assignments shall get correctly remembered and load again. Please try again.


Thank you, Ulf. So far, so good! I did what you said – I wasn’t sure what “close it” means in this context (I go between different projects, but am I closing them when I do so?), so I saved everything and quit, then reopened Dorico, and the sounds are all remembered.

There’s still an anomaly, though: when I first play my (2-bar) orchestral score (even if I just move to another project and then come back), it plays with that First Contact sound. If I let it finish and then ask it to play a second time, it plays with the correct sounds. This happens each time I try this. If I look at the HALion window for it, the sounds are correct and then playback will be correct too. So that is still odd.

However, gratifyingly, I just created a small new ensemble score, played it back, and all the instruments were correct without my having to assign them. And they are perfectly remembered even if I go to another project and come back. So the problem applies only to scores (only to ensemble scores?) created before the HALion window decided to start working right.

Thank you again for your help, Ulf.

My thanks to Ulf as well. :smiley:

I had a short string quartet example that was fine before the update, but after updating it only played the first line (violin 1) and had that “First Contact” sound applied to it. I was able to choose the individual instruments but they would not sound and I could not get rid of “First Contact” until I used the Play ->Apply Default Playback Template… which fixed it.

My only remaining mystery (and it’s in the lowest possible category) is why there’s an ellipsis (…) after that command when it doesn’t lead to anything, at least not for me. It reset things and they worked.

BTW, I tried using Kontakt 5 as well as the Vienna Symphonic Library Solo Strings and both worked fine before I found this thread, so it seems to be a HALion SE issue.