No playback in Cubase with Focusrite Scarlett 18i20

Ive been using Cubase for now 7 years and just recently upgraded to Cubase 8 running on MacBook OSX 10.11.6 EL capitan. I just acquired a Focusrite Scarlett 18i20 and after downloading latest mix control and reading every trouble shooting guide and comment there is, I still can’t get it to record or playback and music. I’ve tried and different daw (garage band) and everything works fine. I love Cubase and just know it’s a setting error or something. I’ve tried re downloading the daw and new mix control and still nothing. I can hear back iTunes but nothing when the program is open.

Any help would be awesome

Driver of Foc. Scarlett 18i20 works fine with other Sequencers?

What happens, when you want to change the ASIO-driver for the VST-Audiosystem under "Device Setup…-> “VST-Audiosystem”?

Hi Xtombstonex,

I’m sorry to hear that you’re having some problems with your 18i20.

Cubase was made El Capitan compatible after update 8.0.30 - have you ensured that you’re using this, or a later version?

If the problem persists, please feel free to get in touch with us directly and we’ll do everything we can to help:

Best regards,
Jack // Focusrite Technical Support