No recognition Audio CD tracknames at import

When I want to Import an Audio CD with WL7 (7.2.1) the function of recognising the track titles does not work. Also not after refreshing. Neither the 32- or 64-bit versions.
On the same system I also have my WaveLab 6, and WL6 has no problems in this maner at all. So it’s not a FreeDB issue I think, but has something to do with the WL version.

What can it be?
Is it a known issue?

Works here - but I seem to remember I had to jump through a few hoops to get it happening.
Cannot remember details, but it certainly works for me.

Hi,

check Options in the Audio CD reader dialog
or go to menu “Rename tracks”
Search track names on the Internet (FreeDB)

regards S-EH

Yes, I always try this several times. Yesterday it worked at one CD. But the other 7?
Then I closed WL7 and sterted WL6. There it worked just fine again…

Somebody with the same problems?
Does anybody have any clues for me?
I still got the same problem.
Track titles aren’t recognized and displayed in WL7, both 32- and 64-bit versions. Track titles are recognized and displayed just fine in WL6…

The problem seems solved after deleting a file. This was recommended because of my problem with the cc121 controller (not functioning). cc121 problem still isn’t solved. But this problem with recognizing tracknames seems to be.

I’ve just recently had to use this function again which I know was working previously and now I find that, although the CD is correctly recognised, no track names are actually imported. Behaviour is the same in both 32-bit and 64-bit versions of WaveLab 7.2.1

Perhaps there’s been some change on the FreeDB service? I can’t find any option in WL7 to check how it’s set up.

I may be wrong, but doesn’t this have to do with ISRC codes.
I seem to recall no track names are imported from freedb if those codes are not extracted…

As a test I’ve tried a couple of CDs, and even those with ISRC codes are not recognised. Using “Extract ISRC codes” from the Functions menu I can see the codes displayed in the ISRC column, but names are still not found. I can go on freedb.org and manually search for the title and it finds everything no problem.

The problem is also not consistent because in at least one case (an older classical recording) it does find the names! This is what leads me to suspect there’s an issue with the interface between WL7 and freedb. In addition, I’ve tried a different application that also queries freedb.org and that functions perfectly on all tested CDs, so logically the fault can only lay with WL7.

Did anyone get to the bottom of this? It has bugged me for ages and only now did I look and find this post.

It is definitely not a FreeDB issue, as it recognizes the disc (sometimes asking you to chose which of several matches it is). It just doesn’t write the track names into the import dialog.

I don’t think so for 7.2.1, but in the meantime I’m on 8.0.2 and although this is not a function I use very often, it no longer appears to be an issue in WaveLab 8.

Hi,

Try update drivers from GEAR
http://www.gearsoftware.com/support/drivers.php

regards S-EH

Thanks very much. I should have said that this is on a Mac system. Are there drivers for Gear Mac?

More to the point, what version of WaveLab are you using?
IMHO it’s not the CD drivers, but it’s worth a try – and no, I don’t know if there are Mac CD driver updates.

WaveLab 8.0.3 will fix a problem here.

Excellent :slight_smile:
Can we also please have a fix so that “XX name” actually puts 2 digits (leading zero) for CDs with less than 10 tracks? i.e. “07 trackname” instead of “7 trackname”.

I am using 7.2.600, similar to the OP’s setup.

I know that I can upgrade to 8, but it was working perfectly in 6, so why should I need to do two upgrades to get back to what I had originally?

So that’s it - get the new one to have what I had two releases previously???

Probably not what you want to hear, but this issue has been fixed in 8.0.3, fwiw.