No. Score Printing Does not work as expected in 7.0.6

No it doesn’t. There has been no change; it is broken in the precisely the same manner as 7.0.1, through 7.0.5

**- PDF printouts are still 17 times the size they used to be, depending on content. (based on Windows Cubase, previous Cubase versions, Finale, Sibelius, Word,
\

  • Cubase still freezes if you try to replace a same-named file in the PDF print dialog.**

So I can’t send a piece of sheet music more than 3 pages long through email to colleagues.

These bugs were introduced in 7.0.1 (January 2013) and are the same in 32 and 64 bit.

Repro:
Open a track in Score Edit
Switch to page view mode
Print the score to pdf.

Result: File is 17 to 50 times larger than it should be due to the method used for printing. (the pdf contains a image file, rather than, well, vector data, I suppose)

Repro:
Open a track in Score Edit
Switch to page view mode
Print the score to pdf. Use a file name that already exists when the save dialog comes up
Hit Save

Cubase is now unresponsive. You cannot use the mouse or keyboard to click on Cancel or Replace, to dismiss the save dialog.
The only way out is to force quit.

edited for clarity and tone :wink:
Test Print Win.pdf.zip (48.5 KB)
Test Print Mac.pdf.zip (864 KB)

Hi,

Just wondering what image format should the PDF contain if not TIFF?

PDF files should be vector and font descriptions as well as other programming, not image containers. (Please start a new thread if you want to have a conversation about PDF formats)

I added files to illustrate in my OP,

I see what you’re saying there, your Mac file size is giant! I’ve only got a PC here and I print using the CutePDF printer driver which exports similar to your file, in a note font (vectors/fonts I presume) rather than one single image, thus a small file size. Does the Mac use a printer driver too? Could it be something to do with the PDF generator rather than Cubase?

In CutePDF I can reduce the file size by compressing the images (JPEGS), would this help you?

Mike.

The printer driver is built in to the OS, there are no 3rd party options available. (that work)

It is up the the developers to use the correct method to print. (I know, easy to say)

Aloha guys,

For some reason none of this is happening here.
Tried the repros (4x) step by step and nada.
Printing happens with no probs.

I get afraid when I read threads like this one.
C7 was the first version of Cubase that I was able to use
to ‘ween’ myself off Sebelius for notation work.

So far so good but this BIG PRINTING THANG has me shaking in my boots.

Hope you guys get it sorted.

{’-’}

I’ve not had a chance to test the size issue, but I’m hitting the same problem with Cubase becoming unresponsive when trying to print a score to the same file name. I can access the Cubase menus , but all the options are greyed out.

Hm. If it’s working on your system there must be a way for others to get it working. Did you have this problem in 7.01 - 7.05? I see you have updated to 10.8.5 on your big machine, I’m still on 10.8.4. Have you tried it on your laptop (with 10.7.x)? (and it only has to do with printing PDFs…) I’ll update my laptop to 10.8.5 and have a look, maybe the fix is therein…

EDIT: after updating the laptop to C7.0.6 and Mac OS 10.8.5, no change.

btw, this problem was confirmed by support back in February-

This is something that they are aware off and it related to the change apple made with how developers develop for 64bit. I can’t give you any eta on when this will be fixed as of yet but i just wanted to let you know both issues have been reported and are being looked at.

Thank you
Jeff Deno
Steinberg Support

Aloha guys, This is weird.

Did you have this problem in 7.01 - 7.05?

No. And 10.8.4 was working fine as well.

However I have had this issue while using C5/6/6.5.
It was one of the probs that made me stick with Sebelius.

Have you tried it on your laptop (with 10.7.x)?

No. I only use the laptop for playback
doing live on-stage work.

I have never tried printing from it but I will give it a try early next week
(after all my weekend gigs have been completed).

Anyway it looks like on this issue Steiny is on the case.

The question is: why does printing work correctly for me?

A lil printer info (that should even not matter).
I’m using a <4 year old Epson RX585 printer (they don’t even make them any more)
and over the years I have printed 871 CD/DVD labels on it. (I just checked)
{’-’}

Hm. Are we talking about the same thing? I’m talking about PDF files only, not printing to a printer.

Aloha Steve,

Just to be sure. Last night I did this 4x:

Repro:
Open a track in Score Edit
Switch to page view mode
Print the score to pdf.

No probs.

Then I did this 4x:

Repro:
Open a track in Score Edit
Switch to page view mode
Print the score to pdf. Use a file name that already exists when the save dialog comes up
Hit Save

No probs

But this was after a gig so it may well have have been pilot error.

So today after coffee I tried both again 1x (right now).

1st example: Still no probs.
2nd example PROBS! as described.

—go figure this one. I’m sad. :frowning:
{’-’}

If you can stand it, :wink: What was the size of the PDF file produced in any of the scenarios?

Aloha Steve,

Just got home and read your post.

Using a one page score document,
from the ‘Get Info’ window of the pdf:

Size: 536,530 bytes (537 on disk)
Resolution:612x792

The saved pdf opens normally on my screen and prints the same way.

I had to use the app ‘Preview’ on that machine to open any pdfs
because I have no Adobe products installed.

We will get to the bottom of this i’m sure.
{’-’}

Here is an interesting turn.

I said:

The saved pdf opens normally on my screen

And they still do. In ‘Preview’.

But

if I open that same pdf sitting on my desktop in Apple’s ‘QuickLook’ app,

IT IS GIGANTIC! I cannot see it all.

Why or sup wi dat?

This is getting stranger and stranger.
{’-’}

Yep it should be only 45kb. (a 4 page score is over 5MB)

As

That’s weird, I don’t know, I think it has more to do with the Quickview pane somehow being too zoomed in, and not the file size itself… That doesn’t happen here anyway.

Jeff at US Support confirmed that these two issues are supposed to have been fixed, but apparently they were not. I’m waiting for his next response.

to be cont’d…

Confirmed. Cubase locks up and requires Force Quit. c7.0.6

I heard back from Steinberg support.

In regard to the giant PDFs, I interpreted the response to say this is not going to change soon, it works as designed, though they did say they would keep it on their radar. I think it has to do with changes to OS X, and priorities at Steinberg. One view could be that a 10 MB pdf file (5-8 pages) is trivial to upload and download, since people are sharing lots of similarly large files.

In Windows PDF printing drivers are all 3rd party, and there are several options, on Mac there are no real options that I could find aside from the system driver. (Don’t know why)

I’ll just upload the large pdfs to my web space, or dropbox etc and send links. Not as nice as before, for sure.

In regard to Cubase becoming unresponsive in the PDF save dialog when saving duplicate filename, I’m waiting to hear back definitively. That one is a clear bug, so as slow as it’s going I suppose it will eventually get addressed.

I can’t really complain, there’s a lot thats good in C7.

Do what I do if you still have 6.5 installed. Create the score format it and save it. Close Cubase 7.06 and open Cubase 6.5. Open the same file and format it again and touch it up. Now save it with a slightly different name, I add print to the title. Now print it to PDF and it comes out normal like it always did. This is not an OS MAC 10 problem as I have 6.5 on the same Mac as 7.06…it’s a Cubase 7.02 and up problem.

Lee

Well, okay, it’s a Cubase problem.

That’s a bit more trouble than I’m willing to go to just to keep the file size down.

There is possibly another workaround, some people have Virtual Box or other virtualization software and can run Cubase on Windows in it. This would not require rebooting or reformatting, possibly.

I don’t know enough about programming to say with certainty what happened. They say they’re not going to fix it, I have better battles.

I do have a “left field” workaround suggestion :wink:
Re-install Cubase 7.0 alongside Cubase 7.0.6 (simply rename your existing “Cubase 7.app”, temporarily, so that the re-install doesn’t overwrite C7.0.6).
A quick test here shows that, when a 7.0.6 Project is loaded into C7.0, the formatting seems to remain intact (although you may need to double-check the page size in “Printer Setup”).
You can now Save as pdf (with the file size the same as it was in Cubase 6.5.5 32-bit… remember C6.x didn’t print at all on Mac OSX, 64-bit :wink: ).
Yes, the pdf does have the non-proportional scaling problem (which brought about the change in the Cubase OSX printing code in the first place :stuck_out_tongue: ), but, so long as you don’t mind having some lines (and some symbols, such as slurs) printing too thick, you might be agreeably surprised by the result :wink:.