no signal from keyboard in cubase

Hi everyone,

I purchased a first very modest midi keyboard two months ago. I didn’t get it to work with cubase though. After searching in the operation manual and various fora i wish somebody could help me on my way, because it’ s starting to get annoying walking around in circles…

The problem is that no midi signal seems to be registering in cubase; the transport panel does’t show any signal when hitting a key. However, everything registers fine with the virtual keyboard.

I assume there something wrong with my cubase settings, but i have been unable to figure it out. Any help would be highly appeciated. Some checklist with all necessary steps to make this work would make my day!

Fyi: keyboard is an akai mpk mini2 - the one with a little red joystick - with usb
connector. Secondly, i’ ve started using cubase only this year, so difficult learned words may further confuse me instead of clarifying things.

Thanks a lot in advance

Hello,

First of all you should make sure that you have the latest drivers installed for your Keyboard, In case it has you will find them in the manufacturers website.
Then make sure that your operating system recognises the device.
Once the OS recognises the device you should start Cubase in case you are in Windows.

Best regards,
GN

Thanks Guillermo for your reply,

As far as i can tell, both are ok: Windows recognises my keyboard; the keyboard itself is supposedly plug and play, so no driver software was installed. Anyways, i will check this to be 100% sure.

In cubase device setup, can you see the keyboard listed in the list of MIDI in and outputs?
In the menu bar, click devices, then device setup. Select the midi port setup tab on the left of the window that appears. That is, assuming it still looks the same as it did in Cubase 6 which I use :wink:

Hey Strophoid,

Thanks for the advice, I added a screenshot under attachment.
port setup.PNG
Everything is as you say, as far as i can tell. Except maybe the fact that the midi out option with my audio interface (UR22) is inactive. I don’t fully understand how the midi is flowing through my setup anyways. I mean, the keyboard goes directly into my laptop; the output from Cubase goes through usb to my audio interface, which sends it out to monitor speakers. Am I missing something here?


Having the keyboard recognised by Cubase already proved to be a hustle; according to the akai website the keyboard needs to be ‘installed’ as a generic remote. Which is what i did. So i guess some adjustments need to be made there as well. so far i haven’t done anything for fear of fiddling with options beyond repair. The second attachment shows the settings as they are now.
generic remote.PNG
Suggestions are more than welcome!

thanks for trying to help out!

That looks fine indeed. And you’re not missing something, that’s how it should work. I’m a bit surprised Cubase detects the keyboard but registers no midi activity…
Have you tried creating a midi track or a vst instrument track, setting the input to the keyboard and see what happens when you play something? If the transport bar doesn’t show any midi activity my guess is it won’t work, but to be honest I’m a little baffled here…

Having the keyboard recognised by Cubase already proved to be a hustle; according to the akai website the keyboard needs to be ‘installed’ as a generic remote. Which is what i did. So i guess some adjustments need to be made there as well. so far i haven’t done anything for fear of fiddling with options beyond repair. The second attachment shows the settings as they are now. Suggestions are more than welcome!

thanks for trying to help out!

You’ll need generic remote for assigning functions to the faders etc. For the keys you shouldn’t need generic remote. If there are lines in generic remote for the keys, I suggest you remove them. The keys should be easy to get working, once they do we’ll take a look at the other controls.

it’s been some time, but i got round to trying it again…
I added both midi track and vst, both dit absolutely nada…
Any ideas further? I noticed that the letter keys in the transport panel don’t produce a signal either. However if i use the corresponding keys on my actual typing keyboard, there is a signal. I don’t even know if this means anything. Getting somewhat frustrated here…

thanks anyways for replying and trying to help out!

Oh and two screenshots, in case i’m missing something in the setup.
example_vst.PNG
example_midi.PNG

A few things to check…

1 - Make sure your keyboard is turned on and plugged in before starting Cubase
2 - Some keyboards have a specific button (or some other button/key press sequence) to activate the midi. Check the keyboard manual for that requirement (there may not be one for yours).
3 - For input routing choose “All MIDI Inputs” instead of whatever yours is called (MPKmini2)
4 - Don’t forget to choose an instrument in Halon Sonic SE. I don’t see one listed but that just might be because you do not have “Instrument” visible in the inspector.
5 - Check out this vid… I know it’s not the “2” version but it might be similar.
https://www.youtube.com/watch?v=UH4jt2zAMDg

Take two pills and report back the results. Good luck :wink:

Regards. :sunglasses:

Just to be very sure try enabling monitoring on the midi or VST instrument track. (the speaker icon next to the red ‘record enable’ button. It should turn orange)

I took my two pills, so here it goes;

  1. check
    2.no buttons to push (but there is definitely midi going into the laptop, i checked with midi OX)
  2. no quite sure what you mean with input routing, but i think i did it anyways :slight_smile:
  3. i’m - again - not too sure, but i think i selected an instrument in Haleon Sonic SE (honky tonk piano)
  4. I watched the vid, but i guess this is for setting up the pads and knobs on the Akai keyboard. Do i have to do this before actually getting sound from the keys themselves?

6.did the monitoring part

All in al, everything produces sound now; the pianoroll, the keys on my laptop keyboard, the letterkeys in the transport panel. The keys from the Akai though don’t do anything so far.

Could i still be missing something in the midi device manager in Cubase or any other setting in the devices windows in Cubase?
test_3.PNG

To question 5: I don’t have your exact controller so I can’t give you specifics but, I would load all the software that needs to be loaded to get sounds from the pads and such. If you are already getting sounds from the Akai pads but not the keyboard then maybe the device is bad. Regardless, maybe a question to the Akai support staff is necessary.

My last few suggestions…

  1. if connected to a USB hub make sure it is a powered hub.
  2. for the heck of it try using the Akai on an “instrument” track instead of a “midi” track (or vice versa).
  3. try a different vst instrument software instead of Halion Sonic SE if you have one.

Sorry I can’t think of anything else right now so I hope one of these helps.

Regards. :sunglasses:

Ok, i will try your suggestions over the weekend. thanks!

I just installed a demo version of Reason by the way. It took me under two minutes to get my midi keyboard producing sound. I’m just saying…

Yup…

Same thing has happened to me today…

My Keyboard work in all stand alone plugins… (Massive,Groove agent 4, FM8, Abelton 9, Reason 7, Reaktor)…
But not in Cubase 8.

Very Strange…

There is no midi activity at all…
Yet, My Akai MPD32, SparkLE,Midi Fighter and Panorama P1 all work fine…

Hello,

Boris, did you have any success with this issue? I am also stuck!

BR,

Are you guy using the AKAI MPK mini 2 with Cubase AI 8 by any chance? Could it be that this controller is not compatible?

Please let us know if you ever got it working.

I bought an M-audio Code61 midi controller in November and has still not been able to use the keys with Cubase. I am searching Cubase forums and M-audio forums, but has not found a solution so far.

After a lot of trials I finally started from scratch and reset my CODE61 to factory settings. Eventually it worked.

In case this may help other CODE61 owners, I made a list of actions you might try:

  1. RESET m-audio CODE61 to factory settings: Press PAD OCTAVE + and PAD OCTAVE – while you power up CODE61.
  2. Select preset «HY-CUB» by pressing the up-arrow 5 times.
  3. Press the Button mode button once so all buttons become green.
  4. Press the Fader mode button once so the button becomes green.
  5. Press the Encoder mode button once so the button becomes green.
  6. Press and hold the SHIFT button while you press one of the Bank buttons twiceso the Bank buttons become green.
  7. Start Cubase
  8. In Devices  Device Setup, make sure that Mackie Control is listed under Remote Devices
  9. Click on Makcie Control, and select All MIDI inputs as MIDI input. Click Apply and OK to close the Device Setup window.
  10. In Devices  Plug-in Manager, verify that the path for the Hybrid plug-in is listed in the lower window (VST 2 Plug-in Path Settings).
  11. In Devices  Plug-in Manager, verify that the Hybrid_x64 is listed as an instrument under the VST Instrument tab in the upper window.
  12. Close the Plug-in Manager Window and create a new, empty project.
  13. Add a new instrument track, and select Hybrid-x64 as instrument.
  14. In the Inspector window, make sure that All MIDI Inputs are used as input routing, and Hybrid_x64 is used as Instrument.
  15. Verify that all of the transport buttons on CODE61 are working with Cubase.
  16. Verfiy that fader F2 on CODE61 can be used to control the volume of track 1 in Cubase
  17. Verify that encoder E1 on CODE61 can be used to control the panning of track 1 in Cubase.
  18. Start recording and verify that both the keyboard and the pads can be recorded.

Nice one! :slight_smile:

Yes I thought so, but the weird thing is that I can repeatedly do exactly the same steps, and some times it works - some times not. I have also observed that my CODE61 starts sending MIDI data to my computer, and after a while (few seconds to several minutes) the stream of MIDI data to my computer stops. So perhaps some other processes on my computer closes the MIDI port, or maybe there is a bug in the CODE61 software. I have had M-AUDIO support check my Cubase setup via Teamviewer, and it looked all right. Now I am using MIDI-OX and Bome MIDI Translator to monitor what happens.

Hello,

Then your computer is probably dropping the USB-MIDI device. Please read the following knowledge base article:
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/windows-issues-with-usb-devices-due-to-usb-selective-suspend-in-power-options.html?tx_p77sbknowledgebase_pi1[keyword_search]=USB

Best regards,
GN