no slashes although created in the percussion kit

Like I said: it’s my cursed day today :smiley:
I don’t get slashes on my drum stave when inserting the note ‘B’ - I get normal noteheads - although I created a slash on ‘B’ in my percussion kit -> see attachment.
What did I do wrong please?
Thanx a lot
The Quest 1_18test.dorico.zip (839 KB)

I created a new file/score, added drums, added a slash in the percussion kit and everything works fine - I get my slashes when playing ‘B’ on the keyboard. I go back to my ‘old’ score, do the same thing and I don’t get slashes but normal notes. Ahhhhhhhhhhhhh

To enter notes in a drum kit, it’s best to navigate the cursor vertically, and use Y to enter the notes.

Hey Dan,
even then the problem is still there…wrong noteheads.

Have you edited your drum kit to make sure that you have the desired noteheads for each instrument in the kit?

Setup mode, click on the player, and edit the percussion kit there. You can set noteheads and stem direction for each instrument in the kit.

Like I said: slashes in my percussion kit on note ‘B’ but it doesn’t work

Whether or not you get slashes when you play a B on your MIDI keyboard will depend on the settings you have chosen on the Note Input page of Preferences for whether you’re using staff position or the percussion map to determine the input pitch.

Thanx Daniel…also here everything is right…see screenshot 1…
I should get slashes when entering a B on my keyboard…even then, if I use manual input, and I go manually to ‘B’, I can see ‘SL.’ in the score. I press ‘Y’, I get a normal notehead…see screenshots 2 and 3.
Sceernshot3.png

I thought maybe the problem was the triplet or that I chose slashes without stem…so I changed that…same result…screenshot 1 to 3
Screen2.png

Could the problem be that I don’t use the GM percussion MAP but a map which I created by my own? So that the slashes in the percussion KIT only work with a GM or Yamaha percussion MAP?

you can create an instrument in the percussion MAP called ‘Slashes (with stems)’ or one which is called ‘Slashes (without stems)’ BUT you can’t create the same instrument within the percussion KIT. IMHO that’s the problem. If you could create a ‘slashes-instrument’ in the percussion kit with for example a ‘default-slash-notehead’ you could treat it like any other instrument in the percussion kit.
Like it is now there is no use in having a Slashes instrument in the percussion map cause you can’t assign it in the percussion kit. but as usual I guess I’m completely wrong and the guys from Dorico have an explanation for all that :smiley:

B is the middle line on a treble clef staff. You should try changing your percussion input options to see if that helps.

Thanx Derrek,
that was one of the first things I did (see posts above) - among all other options in cases like that.
I really think it’s a problem that I use a plug in for the drums and my own percussion map and kit. I guess that causes the problems.

Nobody ever made the same experience with a percussion map other than GM or the ‘integrated’ Yamaha?

I’ve spent some time looking into this but so far haven’t been able to figure out what’s wrong with this particular project. I have asked one of my colleagues to take a look and we will report back in due course. Please be patient with us (if you can).

We did discover the cause of this on Thursday. Go to the Percussion page of Notation Options and set the ‘Voicing for drum set kit presentation’ to ‘Use voicing defined in kit editor’ rather than ‘Use single voice’. When you choose ‘Use single voice’, then everything – including the slashes – will be squashed into a single voice, and that voice cannot show slash noteheads. So if you generally want to make it appear that all of the instruments in the kit are assigned to one voice but still use slashes, you should assign all of the instruments to the same voice in the Edit Percussion Kit dialog instead of using the ‘Voicing for drum set kit presentation’ option.

Cool. Thanx

the slashes problem in the percussion kit is so complicated…it’s not solved yet guys, sorry.
Ok Daniel, if I choose Notation Options and set the ‘Voicing for drum set kit presentation’ to ‘Use voicing defined in kit editor’ rather than ‘Use single voice’ I can use slashes - that’s fantastic…but the disadvantage is, that I get things like that, which is completely confusing:
Bildschirmfoto 2019-06-20 um 17.50.44.png
So if i set it to ‘Use single voice’, it looks fine again, but I can’t use slashes anymore:


That’s really a big problem for me, sorry. I can’t write decent scores for my drummer with Dorico at the moment guys…

What about just using 2 separate staves for drums, one for display and one for playback? Set up another instrument as the display staff (then change the name) so you have the full range of editing capabilities and aren’t limited to what you can do with a percussion staff. Create slash regions or slash noteheads as needed in the display staff, and make the playback correct in the other percussion staff. Just hide the playback staff in the final score.

Thanx man…the best solution up till now though I have to change notehead shapes and stem-directions all the time. But at least it looks like it should be at the end…fantastic ! Thanx again.