No sound (Catalina)

I created a new song, wrote a few bars and tried playback… no sound.

Tried changing various settings in Playback device… still no sound.

Reinstalled Dorico… also no sound.

Deleted the VSTAudioEngine3 folder and restarted Dorico, same thing.

It keeps complaining about a missing playback template whenever I reopen the file.

I also generated a diagnostic report, although I have no idea about where to find it.

Created a new song with the same instrument, and now I have sound, but the song two hours ago still have no sound.
Copying all the notes to the new song fixed the issue, but at the cost of a few hours lost debugging, without actually finding the root cause.
I hope my new song will continue to have sound.

So limited time for being creative, and you end up spending it on broken tools, what a bummer :frowning:

A. Have you updated Dorico to 3.0.10?
B. Did you try reapplying the playback template?
C. If running NotePerformer, did you install either the patch for 3.0.10 or the newly released NotePerformer update?

What playback template are you using? Play mode—Play menu—Playback template.

If it’s HSSE, do you have that properly installed?

I patched with 3.0.10 first and did a full reinstall of 3.0.10 afterwards, none of which helped.
I have tried applying both available playback templates HSSE(Elements) and HSSE+HSE(pro).
Settings are the same on the two songs, one works one doesn’t.
I don’t know what NotePerformer is, so I’m probably not running it :slight_smile:

“If it’s HSSE, do you have that properly installed?”
What does that mean? I have no idea what HSSE is, it came with Dorico, didn’t it?

Sorry for my bad manners, thank’s for your fast responses.

What about Reset Playback Overrides, also on the Play menu?

Settings can’t be the same on both projects, since one works and one doesn’t. It’s just a matter of figuring out which settings are changed.

Can you confirm that you can go back and forth between one and the other, and their playing or not-playing is consistent? Or is it working now in both projects? If it’s the latter, then there’s a setting (probably) in Preferences that has been changed for the better, and that setting will apply to all projects. If it’s the former, then it sounds like a playback template issue in the project file itself.

I have been jumping to and from both while writing, and only one of them works.

Reset playback overrides didn’t change anything.

They both appear to have the same playback template HSSE (Elements)

Hmm. The next step would be to zip up both projects and post them here so someone else can take a look.

Here they are. One of them has a “-working” suffix in the file name.

Thanks a lot, you are being most helpful. (703 KB)

Hi Brian, the not working project does not have a VST instrument (the one that shall produce the actual sound), so Dorico does not know where to stream the MIDI data to.
If you go to Play Mode and then choose from the menu Play > Playback Template and then the HSSE template, it shall reinitialize everything, load the instrument and appropriate sound patches.
By the way, when you do Help > Create Diagnostic Report a zip file gets created on your desktop.

I have actually switched Playback Template quite a few times without any change, seems the reinitialisation is not working on my computer.
Dorico (318 KB)

Then that project got into a funny state. But you have a version of the project that does work, right? How did you get that one into place?
Also, what if you start a new project from scratch, does such a project produce sound immediately (after entering some notes)?

If so, Brian can copy the notes from his silent project into a new file, perhaps even XML them across.