No sound from monitoring

I am using Cubase 10 Elements on a Windows 10 PC with ASIO4All and I am unable to get any sound from monitoring.
Playback works just fine, but neither ASIO Direct monitoring (option is greyed out) nor monitoring via Cubase work (no sound).

I’d be thankful for any help

Hi and welcome,

What exactly do you mean by “monitoring”? Do you mean to monitor the incoming signal while record?

Make sure the Monitor button is enabled on the track. Try to increase Audio Device Buffer Size.

Yes, I do mean exactly that.
I’ve tried all both larger and smaller buffer sizes and none worked :confused:


Can you see the meters on the track while recording & monitoring?

Could you maybe attach some settings screenshots, please?

Yes, I can see the meters for the playback, but the notes I try to record don’t make any sound at all. I can even record notes normally, it’s just that I only hear the playback when recording.

I see, you are talking about an Instrument tracks…

So you have some data recorded already and you want to overdub?

I can see some signal at the Stereo Out. Where is it routed to (Audio Connections > Outputs)?

I’m sorry I didn’t make that clear right away, yes I am talking about Instrument tracks.
Neither when I’m trying to overdub existing data, nor when I am recording new one, I don’t hear what I’m playing.
The Stereo out is linked to my Speakers, as far as I can tell.


MIDI is working a different way than Audio here. By default a new MIDI Part is created and the old one is kept. So if you overdub, you can hear even the already recorded data.

On your side, is it the same if you record to the track for the very 1st time? Can you attach a simple use case screenshot, please?

  • Add one Instrument track.
  • Enable Record and start recording.
  • Can you hear what you are recording? Can you see a meters on the Instrument track? Can you see a meters on the Stereo Out Channel in the MixCosnole?

I can hear the already recorded data, only what I’m recording in that moment is silent. Even when recording a completely new track, I can’t hear what I’m playing while playing. But when I’m only using playback, I can hear the track.


I can’t see any activity in NI Kontakt. Could you please open NI Kontakt? Can you see the LED of incoming MIDI data? Does it blink?

Can you try to increase Buffer Size?

Is MIDI Thru active?

Hi, sorry for the late answer, the program shows incoming midi data, but Kontakt is not responding while recording. A change in buffer size only les to excessive lagging and MIDI thru is active.


Can you reproduce the issue with other VSTi? Or do other VSTis work? What about HALion Sonic SE for example?

Hi, the issue is exactly the same with halion sonic se and all other vstis i tried it on


So again, the signal is not going to HALion Sonic SE? The incoming indicator is “dead”?

Could you try to reinstall Cubase (as administrator) and reset Cubase preferences at the same time, please?

Yes, HALion doesn’t respond at all to the MIDI input.
I reinstalled Cubase and reset the preferences yet the problem still persists.


I’m sorry… Do you know where you would see the incoming signal in HALion Sonic SE, please? I want to be really precise in this, to know where the problem is.

I’d see the key being “pressed down” in the instrument, right?


In HALion Sonic SE you would see a blinking MIDI Channel Number.

The MIDI symbol doesn’t blink while only recording.


While playback… Is the Monitor button and the Record Enable button disabled?

Could you attach a sample project, please?