No sound from Noteperformer. Click playing through midi keyboard


I’m demoing version 4, giving Dorico a shot after I tried version 3 last summer.

I am not getting any sound from Noteperformer, even if it’s selected, or selected as default template, and even on a brand new project with just a piano staff.

Furthermore, I selected the Halion template, and I get sounds from it. But if I play a through my midi keyboard I am hearing click notes rather than piano notes.

Can you help me get my head around it?

Many thanks.

MacBook Pro 14 M1 Pro. Latest MacOS, Latest Dorico/NP

EDIT: ok I realised I needed to run Dorico in Rosetta to use Noteperformer, so that’s sorted.

What about the note input that uses the click sound issue?

Many thanks and best


Hi @mikeheels , is it maybe just wrongly routed? Please go to Play Mode and on the let hand side click on the Inspector tab and there unfold the Routing item. Is it set up correctly?

Hi Ulf, and thanks.
It’s really weird. Now that I switched to Rosetta, Noteperformer works, but I’m hearing either a synth sound when playing through my midi keyboard, or the click sound as described before.

If I switch to Halion, now it looks like it’s not having that same issue as before.

The routing you asked me check looks like this:

Hi @mikeheels, if you have that click sound and then go to Setup Mode, add an arbitrary player and immediately delete it again, does afterwards the expected NotePerformer sound come?
We have a known bug in the MIDI routing area, which it appears you also ran into.

Hi Ulf, many thanks! it looks like it worked. For some reason Noteperformer still shows the presence of the temporarily created player even though I deleted it right away

Hi @mikeheels , that’s a problem of NotePerformer then. Some other user reported that disabling and re-enabling MIDI thru (Preferences dialog, Play tab) is also a workaround.

1 Like

Ok Thanks so much for your help!