"No such file or directory"

I’m trying to open a Dorico project that has an underscore (_) in the both the filename and in the name of the folder in which it’s stored.

When nothing is open previously, Dorico starts up and loads the project just fine.

But when the Steinberg hub is open, and I then attempt to open the project from Windows Explorer, I get the message “No such file or directory.” The dialogue window lists the file path, but it stops at the underscore.

I can open the file from the Hub–> Recent Projects.

In searching the forum, I found a post similar to this from 2016. But I’m bringing it to the team’s attention again, in case they weren’t aware it was still an issue.

If you remove the underscore, does that improve things? It should be a valid character, of course. I had had some files which contained an invisible character between visible letters, and that caused problems until I retyped the whole filename.

I suspect it’s not the underscore that’s the issue, but some other character in the path that makes Dorico interpret the string it receives from Windows Explorer as having two files in it, which of course results in two incomplete and non-openable paths.

No other special characters besides the underscore, and there is only one other file that gives me this problem: a filename with an em dash (—) in it.

Other files in this similar path don’t cause the error message.

Can you share the complete path, please, Dan?

You could also do Help/Create Diagnostic Report which will contain the full path as Dorico sees it, in a file on the desktop called DoricoDiagnostics.zip

Daniel, here’s the file path: C:\Users\Generic User\Dropbox (Generic User)\NAME\Song Files\Come Thou Fount_brass\Come Thou Fount_brass.dorico

Here’s the error dialogue that pops up:

Does it make a difference that there are Back-Slashes in Dan’s file path, and there are Forward-Slashes in the error dialogue?

I’m wondering if Dropbox might be the clue. It might be that that folder is a virtual location that’s dynamically linked or something - I know I read about previous problems possibly with OneDrive rather than Dropbox. Don’t quote me on this, though - it’s far from my speciality.

No, under the covers Qt converts between forward and backward slashes, so that won’t be it. The issue will be that Dorico is interpreting this path as a series of commands. We’ll take a look and see if anything can be done.

Update: Daniel, I ran into this error again. In this case, the file path was:

C:\Users\Generic User\Dropbox (Generic User)\TEXT\Dorico lead sheets - Name\Come, We That Love the Lord - chord demo.dorico.

Other files in this same folder that did not have a comma in the filename worked fine. When I removed the comma in the filename, I was able to open the offending file successfully.

Not sure if that’s helpful…

Having a comma in the filename is certainly a condition that could cause the problem: the comma has to be escaped as part of the string in order for Dorico not to interpret it as two arguments. If memory serves this is made more complicated by the fact that we have some special logic that has to pass arguments to an existing application instance if Dorico is already running to avoid running up a new instance, and there’s some potential for things to go awry there too. This is something we’ll try to resolve in the future.

Further to Daniel’s comment - this is something that generally would only go wrong in the case that Dorico is already running and you double-click from the OS to open the file. I think if you Dorico isn’t yet running, or do you File/Open, or drag and drop the file icon onto a Dorico window then it probably won’t happen.

Paul, you’re correct - I dragged the offending file from Explorer onto the Steinberg hub, and it opened correctly.

Easy to work around until a future fix. Thanks.

Most time I am running in this error, too. For example the file:
e:\Partituren\Klavier\Klavier Unterricht\Bach, Johann Sebastian - Praeludium C-Dur BWV 939.dorico

leaves the error “No such file or directory”. As Daniel mentioned, the comma may be the problem. But a comma in the filename is very usual in german. No chance, to fix it?

I’m having a similar problem
I try to open a dorico file but I always receive the message No such file or directory /var/folders/_s etc
I can’t open it neither in the dorico menu nor directly from finder.
I’m attaching the screenshot of the message
This is the path of the file
Macintosh HD⁩ ▸ ⁨Users⁩ ▸ ⁨juanforero⁩ ▸ ⁨00 Classes⁩ ▸ ⁨Module 4 TSS II⁩ ▸ ⁨01 Pieces⁩ ▸ ⁨07 Creation⁩ ▸ ⁨Creation Score⁩ ▸ Genesis.dorico

please any ideas or help?
Screen Shot 2020-02-12 at 1.33.17 PM.png

Welcome to the forum, juanforeromusic. Does this problem affect every project you try to open, or just one specific project?

Hi Daniel, Thanks for your answer. This happened only to one specific file. What I think happened is I modified the project remotely with one computer, I saved the new file and then went back to my original computer, so probably a kind of cache file or temp file was stored in computer 2 and not available in computer 1 when I went back to it. No such problem anymore.