No swing playback for amateurs?

I’m an amateur jazz musician, I have been using Sibelius for many years, and I now consider moving to Dorico.

But having to buy the pro version, simply for being able to play swung eight notes is really a turnoff.
There must be so many arguments for the pro user to get the pro version, other than swing playback.

I know I could notate it with triplets, but music notation is about readability, and I don’t want to sacrifice that.

For this reason, Dorico is a no-go for me.

I hope this will change in the future, as it looks like a really neat product.

/Brian

Welcome to the forum, Brian. You can certainly play swing in Dorico Elements: simply type Shift+T for the tempo popover, then enter e.g. “regular swing” and hit Return (twice).

Thanks a lot, I’m really glad to hear that and will continue my evaluation.

What about system breaks, pressing Shift-S does nothing, and my score is pretty hard to read without being divided into meaningful bar groups?

Thanks again.

Oh, it actually wrapped my bass line into 4 bar groups, after adding notes to the bars, maybe the defaults are ok.

The Shift+S shortcut doesn’t work in Elements because that’s an Engrave mode shortcut: in Write mode, Shift+S stops a slur. But you will find System Break and Frame Break in the Edit menu.

Thank’s again, you’ve been most helpful.

I really appreciate a company which responds quickly, this is most definitely on the positive-list of my evaluation of Dorico.

About “meaningful bar groups”: You can define a fixed number of bars per system in Layout Mode, no need for manual system breaks if the number is consistent: https://steinberg.help/dorico/v1/en/dorico/topics/engrave_mode/engrave_mode_casting_off_bars_per_system_fixing_t.html

Sounds really good, but here for me, it doesn’t work. My Version: 2.2.20. I have no chance to get access to the swing mode. Any Idea will be appreciated.

What are you doing, and what happens when you do it? Are you using the Shift T popover? What are you typing into it?

I am in the PLAY Mode and I type Shift + T. Nothing happens. No Popover. Have I to enable anything?

The shift+T popover doesn’t work in Play mode in ANY version of Dorico. Select the note or rest where you want swing playback to start, in WRITE mode, then type-Shift+T and Regular Swing then Enter.

Thanks. I can type in “Regular Swing” and it is there as a playing instruction. But Playing the score doesent sound like swing, no changes.

Update: now it works. I started with the old backup and in WRITE-Mode I entered “swing” and after a few types a Popup with teh selction came up. i’m happy now. Thanks fot the help.