No unmeasured tremolo playback if tempo is written with dotted quaver

There’s a strange new issue with the playback of unmeasured tremolos in 3.5.10: it doesn’t work if the meter is written with a dotted quaver. However, it works correctly if the value is halved and the tempo is written with a dotted crotchet.

Way to reproduce the bug:

  1. Input a 12/16 meter
  2. Fill a bar with a dotted minim and apply a three-stroke tremolo
  3. Input a tempo such as e. = 156
  4. Playback the bar. Dorico won’t play the note as an unmeasured tremolo. It won’t make any difference if you decrease the value of the default unmeasured tremolo length in Playback Options.
  5. Change the tempo to q.=78
  6. Dorico will now correctly play the unmeasured tremolo

By the way, it worked fine up to 3.5.


Sorry for the long delay in looking into this. I’ve done some experimentation and in fact I believe you’re mistaken. The attached project plays identically in both Dorico 3.1 and Dorico 3.5, for example, that is to say that the note value of the tremolo is different in each of the two bars, but the project itself sounds the same regardless of whether you play back in Dorico 3.1 or Dorico 3.5.

Both tremolos are being handled as unmeasured tremolos, but the difference in beat unit is not being accounted for correctly, resulting in a different duration for each note in the tremolo being calculated. We’ll take a look at normalising this calculation, so that it always produces the same result, regardless of the beat unit in force at that point. (262 KB)

Thanks for your reply, Daniel!
Oh, I see where my guess was wrong. Interesting.
Nice to know that you’ll take a look at it.
All the best,