No valid License found - cubase 11


I have been using cubase 11 since it was released.
I tried opening cubase today and got the message “No valid License found”. I clicked on Start License Activation and entered my serial number. I got the message "The currently installed version of the elicenser Control is too old.

I downloaded the newest version from elicenser site and tried the whole process again, I got the same error. I tried unistalling elicenser using the windows procedure and then re installed it again. I get the same message.
I can’t use cubase, please help.


Can you see the license in the eLCC application?

Could you try to plug the USB-eLicenser to other USB port?

Hi Martin,

I use Cubase Elements 11, I don’t have a USB-elicenser.
When I open the eLCC app it asks me to perform the soft elicenser repair. I have to open the app as an administrator to perform this. I do this and it tells me that it succeeded performing the process and everything looks fine.
Then I try to open cubase but I get the "No valid License found"message and I can’t use cubase.
Please help me solve this because I need to work on my songs.

now I’m getting this error when opening the eLincenser:

“Application ‘LCC2’ has caused the following error:
Process with the ID NOT found.”

I unistalled the prgram and installed again, I still get the same message.