"No valid license found" in Cubase 7

I have Cubase 7, I got it when it was new, and all of a sudden I’m getting a message saying “no valid license agreement” when I try and open it. I have a lot of unfinished material that I’d like to access. What would people recommend I do in order to fix the problem?

Are you using usb key or soft elicenser? If you open elicenser, what is showing up?

Yes, I am using a USB key

Screenshot 2024-06-05 201248

this is the view of my elicenser

What have you tried so far?

Different USB port? Restarting the computer? Updating the eLicenser software?

Speaking of “computer”, you might want to mention some specs about your system.

Do you have another computer available that you can plug the USB-eLicenser into just to verify that it is still alive?

If using Windows, does the eLicenser show up in “Devices and Printers”?

image

If on Mac, I’m of no help … :neutral_face:

Ok, so your key is not showing up. Is it blinking? As Scab already told you, try different ports and different computers if you can.

I’ve switched ports, restarted computer, tried plugging the USB into something else and nothing comes up. If I buy a newer version of Cubase, will it be able to play Cubase 7 files?

Generally speaking, yes.

You still haven’t gone any further with …

There is also the possibility of recovering your lost license if your USB-eLicenser is truly dead …

Steinberg Zero Downtime – Steinberg Support