No video sound in Dorico 3 with UA Apollo 8

If you have the original broken versions of these project files then we would like to see them so we can investigate the cause of this problem. I don’t think we need the video, just the Dorico project.

Hi Paul, can we send the projects to your email (which is?) rather than posting them here?

Sure, p dot walmsley at steinberg dot de

Hi again,

I think I figured out what the issue is. If my Apollo is set to 44.1 I can’t play video files that are 48. This was not a problem in Dorico 2 but now as far as I can figure out this is why I’ve been having these issues.

I also tried going back to the Dorico 3 version of the videoengine.bundle (after Daniel’s fix) and it works as long as my interface is set to the same sample rate as the audio in my video file.

Thanks for this feedback – I’ll make sure the video team are aware of this change. I guess it’s deliberate, but it’s not something that I, at least, was made aware of when we moved up to the latest version of the engine.

I think I might have an idea of what this could be. When you first load the a project that contains a video into Dorico, the audio track is extracted and saved to a temporary directory on disk, and if required, it’s resampled according to your current sample rate. If the system sample rate then changes then the audio track won’t be playable. Before you start Dorico try going to the folder ~/Library/Caches (I think it might be Edit > Go to Folder from the Finder) and delete Dorico 3 in there. Next time Dorico runs it should regenerate the video soundtrack with the current sample rate.

Smart, that could totally be it. I’ll try it next time I run into this error.

Thanks

Update:

The fix with clearing the cache unfortunately did nothing.

But I figured out when it works and when it doesn’t. If Dorico and my Apollo is set to 44.1 and I attach a video that has audio in 48 it does NOT work.

However if I switch Dorico over to 48 (the apollo switches with Dorico automatically) and re-attach the video it works. I have to re-attach it tho, it doesn’t work right away.

I should add that strangely enough this happens regardless of the version of the videoengine.bundle that I use. I have tried both with the new one and then one from Dorico 2.

Not sure I have anything to add here but I was starting a new transcription of apiece, which I do by taking an mp3, creating a video, and importing into Dorico. Not had a problem previously, but with this new one, sure enough, no sound with the video. Opened it up with D2 and it was ok. So first tried playing within the mixer with no luck including the comment on this thread - didn’t seem to help at all. Next attempt, switched sample rate from 44.1 to 48 and nothing. Then deleted the detached and reattached. Now it plays. Out of curiosity I then switched it back to 44.1 but alas, it changed the pitch and tempo to not be that of the original. Not sure what all this really means - didn’t have the issue in D2. Anyway, I’m not “blocked” now as I have a project I can work with normally - but it is oddly different than D2. Haven’t tried opening old transcription projects to see how the 48 setting is going to affect those…but those are done anyway!

Hmm, just now opened up the advanced config options for ASIO4ALL and noticed that “Always resample 44.1kHz <-> 48kHz” checkbox is not checked. Wonder if that’s the issue? Nope. I set the check box, changed preferences back to 44.1, no change. Then left it at 44.1 detached and reattached video. No sound at all. Reset to 44. Still no sound. Then detached and reattached video. Working again, with same pitch change if I then go back to 44.1

So… lesson learned for now…set preferences to 48 BEFORE loading in the video…and audio will play correctly. Don’t change back to 44.1 at this point as it changes the pitch of playback. So I have a working scenario for my project at least.

Hope someone finds this helpful.

Your experience is consistent with what we’ve found: the soundtrack of the video is extracted and cached at the sample rate in use at the time you first attach the video. If you then change the sample rate, the soundtrack won’t be re-extracted.

Important: I don’t have an Apollo 8, but a NI Komplete audio 6, but the problem is the same.

Has this problem been addressed yet?

I’ve had the strange experience today that a video that was playing its audio fine until Saturday, now has no sound anymore. This was a video I created with the export video option in Cubase since I had no sound some time ago as well, but because of this workaround there was sound.

Anyway, I attached the video in Dorico 2 and yes, there was sound, but not in Dorico 3.
In Dorico 3 I replaced the videoengine.dll as mentioned above, but then also video playback stopped working.Then I tried the ‘change-the-sample-rate’ trick as mentioned above, but also no luck there.
I’ve rendered a new video again in Cubase, but still no sound, so I’m out of options now.

Could you tell me if there’s a solution for this?

Have you changed the sample rate used by your audio interface? If so, the first thing to try is to set it back to its previous value. As described above, the video soundtrack will only play at the sample rate that was in use when the soundtrack was first extracted.

If you can’t get any joy, then the next thing to try is to detach the video from the flow (making a note of any start offset etc. times from the Video Properties dialog), then rename the file to have a different name, and re-attach it. That should be sufficient for Dorico to have to re-extract the soundtrack.

Hi Daniel, thanks for your reply.

I haven’t changed the sample rate between saturday and today. When I ran into the problem with no sound, I tried the option above, so I changed it only then.

I will give it a try to detach, save under a different name and re-attach like you write and see if it works then.

Nothing helped, do you have other ideas that might help? I can work in Dorico 2, but that’s not really a good solution, of course.

All ideas welcome!

I assume you’re on Windows. Can you try closing Dorico, opening Explorer and typing in the path bar:

%TEMP%\Dorico 3

If there’s a directory in there called Soundtracks then delete it. Start Dorico and load the project file again.

If this doesn’t fix it then please go to the Help menu and choose Create Diagnostic Report, then attach the DoricoDiagnostics.zip file that’s on your desktop.

Hi Paul,

You’re right, I’m on Windows, forgot to mention that.
But you guessed right and this did the trick, thanks a lot!

I’m getting this issue. I have a film clip at some sample rate (not sure, probably 44) and my interface is a 48. No audio from the clip. Checked mixer settings, all fine for the video track and I can hear instruments. I didn’t change the sample rate but I cleared the caches (Mac OS) and still no dice. What else can I do?

Have you tried changing the filename of the video and re-attaching it?

Hm, missed that trick. OK just renamed it (the prior name was mangly) but unfortunately didn’t fix it. In the meantime while working on other Dorico issues I did a bunch of things including a big disk cleanup and reboot.