No waveform display in SL One

Hi, I installed Cubase 11 and of course SL One was installed as well. When I tried to run SL stand alone it crashed to the desktop. Knowing that my old graphics(HD3000) was probably at fault I installed a Gt1030 card. Now it no longer crashes to the desktop, but no waveform is displayed. I know it loads the file as SL asks if I want to save it when I attempt to exit, but no display. Happens within Cubase 11 as well.
Any suggestions anyone?

-Make sure you have the latest NVIDIA drivers installed
-If it still doesn’t display anything, you can switch to OpenGL mode (Edit > Preferences > Display > Rendering API > OpenGL) and restart SL
-If it still doesn’t display anything, please send me your log files (%appdata%/Steinberg/SpectraLayers 7.0/logs) to contact [at] as well as a screenshot of the issue

Got it to work,mostly! Installed the latest version of SL from the Steinberg website, remembered to run as administrator and it displays now when using Direct X. OpenGL still crashes to the desktop however. I wonder if my older PC(2600k) is just behind the times.
While using as a plug-in within Cubase, SL works with DirectX or OpenGL selected. I suspect that Cubase has decided which protocol to use and that picking it within SL doesn’t really do anything.
Anyway, looking forward to using it.

Still crashes stand alone with OpenGL. Tested OpenGL with OpenGLExtentionsViewer.exe and then running VLC media player. Both worked fine reporting v4.6 OpenGL. Again, working fine using DirectX do I will leave it at that.