No way to turn off Sysex. Really?

Ive got a few midi files i want to use, but all have a huge reverb setting, and program changers built in.
I’m shocked that I cant edit these out in Cubase AI or Elements, or at least turn all this stuff off.

Am I missing something? I appreciate this version cant have everything in it, but the ability to not have this messing with my keyboard set up makes it un workable. What are the workarounds other than copying all the notes and making a new file with them.

To answer my own question/issue. The free version of Cakewalk does it easily, so thats pretty much decided. Back to Cakewalk i go, at least four MIDI sessions. I was going to upgrade to Elements, but ill still need to use CW, so ill keep to AI.

You can edit and filter and delet SysEx data in Cubase LE even, so certainly you also can in AI and Elements. But hey, you found a way…

Could you give me a couple of pointers as to where i can do i these please? I’d much rather not have to use two DAW’s if i can help it.
Actually to be clear, its not SysEx as i thought, its CC events, dont know if that makes a difference. I had turned things off in the Midi settings but the changes were still happening. I even cut out the first bar so the program change wouldnt trigger, but the Rev send was within the notes section.
I’m still a bit rust with all this terminology.

Ok, i admit I seemed to have jumped the gun. Although I’d prefer the list editor I concede that yes, you can edit CC data, and this has given me what i need for now.
Seeing as i was wrong ive upgraded to Elements to show my commitment lol

You need to turn off “Auto Dissolve Format 0” in Cubase preferences > MIDI > MIDI File.

Hope this helps


Thanks for posting. No, it doesn’t help.