Noise and overdub issues with ASUS Xonar U7

Good evening everyone,

Let me first describe the configuration of my PC and equipment. The PC is a pretty standard one, running Win7 Pro x64. There’s Cubase AI 6 x64 installed. The sound card I use is ASUS Xonar U7 (not the best variant for professional recording, however, I’m an amateur, so it’s enough for me). The setup is a little bit tricky. The sound from Xonar U7 comes through 2RCA-2RCA to a mixer (Alto ZMX52), there’s also a guitar plugged into the mixer via an effects processor (BOSS ME70 if matters). The main output of the mixer is connected to a Yamaha A-S500 integrated amp (then it goes to the passive speakers I have), the AUX OUT on the mixer is connected to a MIC jack on the Xonar U7 for the purposes of recording. However, it does not work well.

  1. If I press the Monitor button in Cubase there’s a noise coming from the speakers which stops only after I disable monitoring.
  2. The main issue - if I record a track and then I want to make an overdub and record a new one, the sound from Track 1 comes into the Track 2 and it makes overdubbing a real pain. I’ve read a lot of forums on this subject and the only “panacea” proposed there was turning off Stereo Mix in Windows sound settings - however, it does not work for me as Stereo Mix has been already TURNED OFF and it was never used before (I DO NOT record sound from Youtube etc.).

Between the publishing of this topic and approvement by moderator, thanks to guys from StackExchange I’ve ruled out the most possible reason: an infinite loop between the output of U7, mixer and the MIC input of U7. So, I will have to change my question to: Is there any way to set it up right (and get rid of the infinite loop) without buying a new sound card for recording?

Best regards,