None of the HALion VST Instruments will preview

I upgraded to Cubase 12.0.60 from 12.0.52 and now I can’t preview any HALion sounds. Other plugins work, such as Padshop and Retrologue. Also all the loops and samples seem to work. For some reason when I select a HALion sound, the VST instrument doesn’t load. It works fine if I create a track using the sound, but the preview no longer works. I tried reinstalling HALion 6, but it didn’t help.

You are right. Same here, no preview from mediabay. Maybe it has something to do with HALion 7 instruments and their new mediabay system.

Same here. Very big letdown. I love the new array of sounds that Halion 7 offers but now it’s such a pity to browse them

Try this if Instrument Preview or Mediabay not working as expected after Halion 7/Sonic install.

FIX - Uninstall Mediabay and reinstall. (Through windows App UNINSTALL) I used the Halion 7 single installation to re install and no issues so far.

Worked for me.

Now it also runs much faster for instrument selection.

This may fix other MediaBrowser issues as well.



Update -

I installed Halion Sonic 7 and the error re-occurred.

My older version of Halion Sonic 3 was uninstalled along with all versions of Halion 7.

The mediabay program was uninstalled as well.

I then reinstalled Halion 7 and Halion sonic 7. The preview error was still there.

I uninstalled the Mediabay program and then reinstalled Halion 7 again. (to setup mediabay)

This time the preview and mediabay all worked as it should.

There seems to be some priority over the installation order and the mediabay interaction.

I think removal of any previous or older versions is necessary before install.

Kind regards

1 Like

Indeed… More informations here (even if a post in it links to this exact thread…) :

No preview sound from HALion Sonic in media browser after reinstallation - Cubase - Steinberg Forums