Not all midi ports work (eg. Hallion, Kontakt)

I’m having a issue where I wan’t to use a midi track to play multiple midi ports 1-16
In my instance of Kontakt I have no problems with Ports 1-4 & 16 all play without issue when triggered from a midi track …
Alternatively in Halion it’s even worse with only port one being able to work unlike Kontakt where I could use 1-4 & 16 halion makes me create a new midi track for each instance of instrument in halion.

How is it possible that Kontakt can work better that Steinbergs own VST?
Or is this a “built in feature”?

Just to clarify, these are MIDI Ports, Halion has A, B, C, and D:
grafik

Each MIDI port has 16 channels. I guess that is what you refer to.
The MIDI channel is assigned/displayed here;

In your screenshot the instrument on channel 3 seems to be playing back something.
Can you please describe the problem in other words?

Specifically in kontakt if I have instruments assigned to host port 1-4 and 16 I can trigger these with one instance of a midi track set to any.
In halion this does not work at all. A midi track must be crated 1-16
In kontakt 5-14
I can’t understand why it half works in kontakt (1-4 & 16) and not at all in halion

Here is a picture of halion with multiple input channels >

And here’s how I want it to work with a midi track assigned to any >

Can you load this project and let me know if you can hear three different sounds?
It uses channels 1, 5, and 8.
Halion_Channel_Test.cpr (484.5 KB)

That works for me although all three don’t play simultaneously. Nor can I replicate it on my end… Everything looks the same. I wonder what I’m missing.
Created a new version used your pattern and nothing >

On an Any track the midi notes themselves must be assigned the channel that they are supposed to play on.

I switched the color scheme of the editor to show channels. You can see the note’s channel in the Info Line.

Make sure that that track is set to Any. (It doesn’t show in your screenshot)

SO this makes no sense >


It plays on 1 and 5 on 5 but only 1 on any

I don’t have Cubase 13 so I cannot check whether I can reproduce anything of what you describe.

To me it looks like there are two possibilities of what is going on here. Either there is a huge bug in Cubase 13 or you are utterly confused.

Hopefully a C13 user that also has Halion7 can take over for me.

Even without a midi track and everything set as you had I can’t seem to generate sound on more that midi 1 >

Because
grafik

Ok :man_facepalming:
Thanks for that. Seriously. Now that I’ve wrapped my head around that back to the question that brought me here.
From our discussion I gather that I can not trigger the instruments simultaneously unless I have created a midi clip and assigned the notes yes?

The only way around this is setting each instance to 1 ie >

Not sure if this is normal but I just noticed that a1 will play even if only channel 2 output is activated? >

Really appreciate you taking the time to help!

METHOD ALPHA:
If you always want multiple instruments in Halion to play simulatenously (stack or layered) then set them all to the same midi channel within Halion (e.g. A1).

METHOD BETA:
If you want to be able to have them also play independent of each other at times, then assign them all to different midi channels within Halion and in Cubase

  • {METHOD BETA 1} use one midi track per instrument, whereas the midi track must be assigned to the corresponding midi port & midi channel
  • {METHOD BETA 2} use one instrument/midi track assigned to Any (as the output!) and assign the correct channel via the notes themselves; with this method you must use the same midi port, though, ie. A, B, C, or D

What you are curently doing is to take a little bit of one method and a little bit of another method. You mix things up and get confused.
Use either only method Alpha, only Beta 1 or only Beta 2.

Disclaimer: the names METHOD ALPHA, BETA 1 and 2 are made up by me only for the sake of this topic and do not appear in Cubase as such.

2 Likes

Thanks so much for spelling it out for me!
Marked as solved :slight_smile:

1 Like