Not allowed to select my interface for audio input

First time Cubase user here.
Setting up the system on my MacBook Pro, everything seems fine except that it will not allow me to select my interface (Behringer UMC22) as audio input.
The interface shows on the drop down menu, and I am getting audio output from it and into my speakers. The issue is when I click on the shown interface, it just closes the drop down menu still showing “Not Connected”.
The system has full permissions, microphone, etc…
Any suggestions or tips on this topic?

Hi and welcome to the forum,

Try to restart your Mac, please.

Make sure Cubase has enabled Mic in the System Preferences, please.
Open macOS System Preferences > Security & Privacy > Privacy > Microphone. Enable Cubase here.

Got it, thank you!