'Not enough virtual memory to load preload samples...'

On a Windows 7/32 Desktop with 4 Gb RAM Groove Agent 4 crashes(!) Cubase 7.5 (with only one GA4 instrument track in the project), after showing the error message "Not enough virtual memory to load preload samples’. It does work in standalone mode so far. Sometimes it just shows the error message without crashing the whole Cubase program.

Huh?

What’s going on here? Virtual memory should be fetched by the Windows system without any problems.
Is GA4 useless on this PC?

Sounds like you need more RAM.

Aloha and +1
to vespesian’s post.

I checked and it looks like 4Gb is minimum.
https://www.steinberg.net/en/products/vst/groove_agent/specs_downloads.html

Good Luck!
{’-’}

Yes, seems so: I checked that it runs without such problems on my music notebook with Win7/64 and 8 Gb.

But this is funny for sure: so far I had no problems streaming big Kontakt libraries or EZDrummer2/Superior Drummer 2 sets, so Groove Agent 4 probably isn’t the smartest program in using resources, and the minimum requirements info mentioned above doesn’t seem to be reliable and should perhaps be changed to 8 Gb.

I will just uninstall the program from my desktop 32bit PC and return to well working Toontrack programs there.

Try and check your Windows task manager, to see if it is a high hit on the memory usage. After all, I’m not sure if GA4 should crash. I prefer a warning instead :slight_smile:

All check out, if you’re loading one of the big drum sample kits. There is a few kits that is rather big in size. If you have disabled your windows virtual memory (page file). If this is the case, it could or probably would lead to more crashes in the programs that need the page file to be used.

SLL

Hi Jimknopf

Further to what has been said here, if possible you should really try and use the 64bit version of Cubase (and thus GA4), even increasing your RAM on 32 bit bit will only help to certain degree. I found changin to 64 bit a few years back made a HUGE difference particularly if one is using large, or lots of, samples, which GA4 uses.

Best Regards

Dave

I have been getting the same message over and over even though I have 16 gigs of 1333 ram installed and my usage is well under 50%! Frustrating to say the least!

@Durbinaudio
have you tried to increase “Max Preload” on Groove Agent´s Options page?