Not fixed in C6: Range Insert Silence less than 1 bar

I sure was hoping this bug was fixed as it was discussed and confirmed on Cubase.net:frowning:

  1. Set grid to Beat (instead of bar)
  2. Set range to 1, 2, or 3 Beats
  3. Edit–>Range–>Insert Silence

Result: NOTHING

Expect: Insert 1, 2, or 3 beats of silence.

Do you have the original bug report handy?

http://www.cubase.net/phpbb2/viewtopic.php?t=119133&highlight=

Brains: do you work for Steinberg? Wasn’t sure why you’re asking but I did dig it up despite the fact that Cubase.net has Search disabled (crazy for an archive…).

I don’t work for steinberg but Chris B. did say we could reference back to the old forum and since it was not included in the current bug list I thought it might be useful.

It looks like maybe you need a time sig track for this bug to repro. Of course I always have one-it’s in my default template. Either way it’s worth fixing in my book. Steinberg did acknowledge the bug in the thread.

I use insert silence (and sig tracks) often, so it’s something I’d want to see addressed at some point.

Process bars was the whole reason I upgraded to C5 from Cubase Studio 5 but now it’s so cheap to buy Artist 6 I might “downgrade” and have two copies because C5 is rock solid on Vista.

Hello lights,

For future reference:-
http://www.steinberg.net/forum/viewtopic.php?p=20200#p20200

(I do remember this old bug… I think the problem was when the proposed length of the Insert didn’t make it cross a barline, rather than the actual length of the Insert).
Anyways, unless I am not trying your recipe correctly, it is working perfectly for me here :confused:

Do you have a time signature track in project you tested it on?

Yes, I do have a Time Signature (and Tempo) Track in the Project window.
I tested it in 4/4 (precisely so that inserting 1 or 2 beats wouldn’t cross a barline).
BTW, if I remember correctly (which I probably don’t :wink: ) I think the workaround was to change the Time sig, temporarily, to 1/4, perform “Insert Silence” then change the Timesig back to 4/4.

It did not work for me. I have a mix of 5/4 and 4/4 in the piece. I use the workaround of inserting 1 bar and then deleting 3 beats of silence. Since delete time works where insert silence fails.

I was just about to go “Aha!”… because I didn’t try with multiple time signatures in the Time Signature track, but I’ve just tried again now, and it still works.
There has to be some other parameter somewhere that must be affecting this :confused: .

Maybe it’s a Windows-only bug?

The workaround I use is to delete all sig changes after the point where I want to insert time, cut and then manually move parts forward. Of course I have to re-enter time signatures beyond that point which is a minor hassle.

Thinking about it now, wouldn’t the simplest workaround of all be to delete the Time Signature track from the Project window (nothing is lost… it is all still there in the Tempo Track Editor window), then perform the Insert Silence, then create the Time Signature Track again?

No. All of the workarounds in the last 2 messages are destructive and require you to recreate time signatures, etc. The one I mentioned above is far simpler. Insert 1 bar of silence and then use range>delete time to remove the extra beats. Deleting less than 1 measure works, it’s just inserting silence that doesn’t.

:slight_smile:

Insert silence is obviously an audio based tool (samples as opposed to bar/beats).

At least there was some acknowledgement in the previous forum. Hopefully someone from Steinberg can comment.

Sorry, you are wrong. Re-read what I wrote.
Try this…

  1. with a time signature track in the Project window, insert several time signatures.
  2. Delete the Time Signature Track
  3. Go to the Project window>Add Track, and add the Time Signature track again… all your previous time signatures are still there. (The Time Signature and Tempo tracks in the project window are merely copies of the data in the Tempo Track Editor window)

Btw, while trying this again myself, sometimes the Insert Silence didn’t work here either (while there was still a Time Signature track present), and sometimes it did (repeating the exact same operation :open_mouth: )

Exactly, this was pointed out in the old forum thread.

Insert silence was designed to work with samples, not meter unless anyone can prove otherwise.

Huh? The Insert Silence that I’m talking about is in the Range menu. It should work on the selection range in the project just like all of the other range commands. Right?