Notation error at key change

I am encountering a notation error when a note is tied across a key-signature change. The notation changes from E natural to D#. I have tried changing the pitch/duration and re-inputting the note - but this still occurs. This is occuring on 2 clarinet in A parts but is only occuring in the transposed view.

That is strange indeed. Have you tried enharmonically respelling the D# using the key shortcuts, or chromatically altering it, before tying? Are you able to get the correct pitches before tying them?

If the first note is not Eb, then it is not compatible with the D# for a tie to begin with (which you know), but I do find that when I tie an Eb to a D# the D# automatically respells to Eb. Try putting the D# in a different Voice before tying; that should work.


I don’t know … this just looks like a bug. The note should not change if it is tied into a key change. If the 5-beat E-natural was already in place when the key signature was added, then surely the default action would be to leave the tied beat as E-natural and ideally add a cautionary accidental.

IMHO, it should not be necessary for the user to do anything by way of a work-around.

Oh I agree. Just seeing if there’s a way around it for the present.

andymcf, please attach the project in which this is occurring so I can take a look and see what’s going on.

It is the Hebrides and occurs at the key change at Fig D Bar 138. I hope I haven’t done something stupid!
Interestingly it plays back OK
I am having difficulty attaching the file - “Invalid file extension: Hebrides Overture.dorico”

Hi Andy.
This forum only allows zip files (and pictures)
The easy way to share a Dorico file is to append .zip to its name!

Any tricks for reducing file size? I have deleted a lot of the content but it is still 2900kb.

File attached with just part of clarinets.
Hebrides Overture - (877 KB)

For future purposes:
Setting the Playback template to silent will clear the HALion player sounds and vastly reduce the size of your file for “transport.”

The second note of the tie in fact is a D double sharp rather than a D sharp, but the accidental is not shown. You can see this if you switch to engrave mode select the second notehead and set the Accidental property to show. In general dorico doesn’t show accidentals on the middle/end note of a tied note, probably in this case it should.

Thank you Derrek and András.
Maybe the main problem is that the notation is enharmonically changed over the bar line. Normally the notation stays the same - even if the accidental is hidden. other tied notes in the score behave “correctly”, but both clarinet parts enharmonically change at the key change.

There’s an option on the Accidentals page of Notation Options concerning enharmonics for key signatures with many sharps or flats – you could try changing it. (I’ve not looked closely enough at the detail of the situation in your original example to know for sure if it will, apologies for that.)

Thanks for the suggestion. This doesn’t do anything in this case, but - unchecking the “prefer enharmonic equivalent key signatures with fewer accidentals” option does stop the notation change - unfortunately the clarinets are now in 7 flats! The only way I have found around it is by writing a separate note and using a slur (slightly edited) to tie the notes.