Note input error or My error?

In measure 5, when I input a normal 1/4 note C (with no natural sign selected) it shows up with a natural sign. Why?
Let add that in Notation Options-Accidentals, it is set for “Common Practice”
Screen Shot 2016-12-16 at 8.19.27 AM.png

I suspect that it’s a cautionary accidental caused by the C# earlier in the previous bar in the left-hand staff.

But if I have “Common Practice” set in Notation Options-Accidentals then this shouldn’t happen. Am I mistaken?
I changed the C# in the previous measure but this didn’t change the C Natural sign.
Also I tried to click the Natural sign in the Not Input Panel to remove it but it wouldn’t let me.

When you choose ‘Common practice’ then Dorico will follow all of the options further down the same page of options for cautionary accidentals, so you should check the settings you have switched on there.

You can hide an accidental you don’t want to see by selecting the note, opening the Properties panel, and choosing ‘Hide’ as the value for the ‘Accidental’ property.

I didn’t change anything from the default settings. I looked at the settings only when I observed the problem. From the common practice settings the accidental shouldn’t appear if it’s in a mew measure. And yes, I do understand about hiding the accidental.

I just changed 2 thins in Notation Options-Accidentals:

  1. Changed from Common Practice to Modernest.
  2. Changed from Show Cautionary Accidentals to No Cautionary.
    This produced the desired result.