Note length snap stuck to 1/4 notes

I’m editing midi note lengths in Key Editor (piano roll), and the note lengths have suddenly begun snapping to quarter notes only - and I mean not to my 1/4 grid lines, but quarter notes relative to the note’s starting position. I can change the quantize value to 1/8, 1/16 etc but it doesn’t affect the outcome. I’m using “Use Quantize” and “Grid” as I usually am. Did I press some hotkey by accident? I’ve gone through all the menus related to snap/quantize that I found but no help. What settings should I doublecheck?


There is dedicated entry for the Note Length quantize. By default, this is linked with the Start Position quantize. But it seems you switched it to the fixed length 1/4.

If you cannot see the Q Length option in the Key Editors Tool bar, right-click to the tool bar, and display it. Then you can switch it back to link with Grid.

Yes that was it! Thanks! Looks like I must have pressed Alt+3 accidentally.

Thank you! Same thing happened to me. This has been driving me crazy!

thanks for this, had the same issue just now.