Note, measure, and system spacing issues

After changing the note spacing I have encounted several huge issues.

Firstly whenever I modify the note spacing of another bar it just disregards the note spacing of the bar I just worked on, meaning it is impossible to properly space the notes on two consecutive bars as they just overwrite each other.

Secondly there is no option to reset the spacing as far as I’m aware, so if I mess up the spacing (which is easy with the strange way note spacing works in dorico) I can’t reset to the default.

Thirdly after working on the note spacing on one page, the previous 2 pages now have 3 bars and 1 bar stretched accross the entire respective page and no apparent way to fix this. The page prior has about 10-15 measures accross it, so suddenly having one page with just one measure is not suitable.

Lastly, is there a way to lock the note spacing on a given measure? It’s super frustrating to have all my custom note spacings constantly reversed.

Thank you

Apologies if I didn’t format the post correctly, never needed to poste here before.

Welcome to the forum! The good news is that this is relatively simple, and we’ll have you sorted out pretty quickly.

In general, note spacing is not one of the first things you should mess with. The default note spacing is generally excellent, and you should manually change it only as a “last resort.”

Instead of note spacing, I would recommend using frame brakes, which you can add in engrave mode. Select the place in the score where you wish the page to break, and in Engrave mode, press Shift-F. Make sure signposts are visible, and you’ll see a purple Frame Break signpost appear. Then add a frame break where you wish the next page to begin… then…

… click on the first frame break, and from the properties panel below, toggle on “wait for next…” That will force everything onto the page until Dorico sees the next frame break.

However, I don’t generally do much of this. Instead, I recommend removing all note spacing (did you do manual note spacing, moving the handles, or did you create a note spacing change?), And instead, in layout options, try changing your note spacing value there for the entire layout. You’ll usually find that Dorico does a great job of spacing things if the user stays out of the way, and only makes manual adjustments at the end.

If you’re putting note spacing changes in, you can easily reverse course by deleting the signpost. I’m guessing based on your screenshots that you do not have signposts set to view; turn them on and then you’ll see what’s going on.

As Dan mentioned, you can simply insert system or frame breaks and this will probably make easier work of it all. shift+s or shift+f. Start at the front and work your way back. You can also use the buttons in engrave mode (there’s a command for it but I’m drawing a blank at the moment) to select a starting and ending point and force things into the same system if necessary.

I agree with Dan, however, note spacing is a finicky way to go about it; set a general rule for the whole score so you get a uniform appearance and only change it in specific spots if you absolutely must. Otherwise, simply putting in frame and system breaks, where prudent, will cause the notes to properly respace anyway and you’ve saved yourself a lot of hassle.

I suppose you’ve been messing with the note spacing sub-mode in Engrave mode (which you can call with a key stroke, but it’s not a default one. Mine is alt-cmd-5.) To reset to default note spacing, marquee select all the red handles you’ve been moving and press delete or backspace. They will turn blue and return to the default state.
Hope it helps!

Thanks for all the responses. I agree, messing with the note spacing is definitely not the best way of dealing with my problem. However once I place a frame break I seem to be unable to select it again, and after accidentally placing one in the middle of a measure this is definitely a problem. Also after placing one frame break at the end of the project to try force the last measure back onto the previous page is just has the effect of breaking up the page to have 2 systems, which with the amount of instruments I have makes for a very messy page.

Also with the pages previously that had only one measure per page, when I tried to use the frame break and wait for next frame break option it forces them all onto one page, but again divides them into multiple systems. Any fixes for this issue?

Have you turned on sign posts? You should be able to see them and modify them.

If you do not see Signposts, turn them on via the View menu. You can choose and delete (and sometimes edit) Frame and System signposts with the selection tool by clicking or right-clicking.

Also, you can set Changes to the ‘Note Spacing’ reference duration (as set in Layout Options) at any point in the score. This can be useful to make a flow fit a number of pages, or just tighten things up/slacken off.

You can’t select frame breaks when the Note Spacing tool is active - switch back to Graphic Editing to select things like frame break signposts.

For frame breaks splitting music into 2 systems - as others have said, reducing the note spacing defaults (either in Layout Options or using a Note Spacing Change from e.g. the start of that frame) might help Dorico automatically “see” there’s enough horizontal space for it to fit into one system. Alternatively, there should be another property for frame breaks, “Wait for next system break” - if you activate that as well as “Wait for next frame break”, Dorico will force all subsequent music after the frame break into both the same system and the same frame.

Do you mean you inserted the frame break at the start of the last bar in the project? Frame breaks push subsequent material into the next frame, rather than pulling back. If you insert a frame break where you want the last page to start, and make sure there are no subsequent system/frame breaks between that point and the end of the flow, using the “Wait for next” properties on that last frame break should pull the rest of the piece into one page.

I had signposts for frames hidden, so making them visible again helped me fix everything. The wait for next frame break was also incredibly useful!

Tusen hjertelig takk!