Note Performer 3 mixer not there, no sound

The Note Performer manual says: “Opening the NotePerformer interface from Dorico reveals our own high-resolution mixer”.

However, the only thing that shows on the NotePerformer window that pops up when calling it from Dorico is the volume and reverb levels, and 3 steps explaining how to set up NP within Dorico (playback template, preferences, then playback from the beginning to assign sounds), even though all that has been done already. No mixer. And no sounds when I play back.

Any help?


Please try following: In Play Mode, choose from the menu ‘Play > Playback Template…’ and then in the dialog that pops up the NotePerformer template.
That shall reset the NotePerformer assignments and the mixer will appear. Also playback shall work then.

What happens if you click this button?


Thank you all for your responses. Everything you mentioned I had already done, plus changing the sample rate too (known bug that made the session crash every time I pressed play).

Yesterday I closed and open the session a few times and nothing changed. Today I just opened it again, the mixer is there, and I get sound now. I haven’t done anything to alter the result, so I’m puzzled…


However, now I face another problem. I imported an orchestral midi file and, for some reason, Dorico/NotePerformer assigned a percussion sound to a bassoon staff. The corresponding channel in the NP mixer cannot be changed to the proper instrument (woodwinds–bassoon), but instead is stuck in a drum kits’ list and not showing any of the other instrumental possibilities. I’ve tried in many different ways, but I cannot change that sound.

Just add a new bassoon to the project, then copy and paste everything on your existing bassoon stave to the new one, then delete the old one.

I already tried that. Dorico is recognizing the new bassoon: not assigning a new channel in the NotePerformer mixer with the proper sound.

There’s an option in the Play menu to assign sounds for unassigned instruments. Have you tried it, after adding a new bassoon to the project?

I meant NOT recognizing…

What happens if you select the existing Bassoon player in Setup mode, then hit the little arrow to expand, then select the Bassoon instrument and Change Instrument? If changing to Bassoon won’t work, what about changing it to Oboe (or whatever) and then changing it back to Bassoon?


Yes, I have tried that. In Play, you can go to the instrument and select what VST you want to use. In my case there are two instances of NotePerformer, showed on its dedicated mixer. One instance is full (16 channels), the other only occupies 4 channels. You need to assign one of these instances to the new bassoon (or whatever new instrument you add to the score) and specify the midi port (1) and the channel. But what channel? Channel 5, as 1 to 4 are taken? Should Dorico/NotePerformer assign that automaticallly to the new instruments, as it did with the others, and create a fifth channel? It’s not happening. How can I force it?

The whole thing is confusing.

You can force Noteperformer to rethink by going Play > Playback Template, setting it to Silence, hitting OK, then going in again and setting it to Noteperformer and hitting OK again.

If I go to Setup mode and do what you suggest, nothing happens. It does take you to the choosing-instrument popup when I try with other instruments, but not with this one. And it’s a newly created instrument…

Same thing with three trombones I newly created. I assign trombone sounds at the Setup screen (in this case the popup opens), but the sounds do not play, and nothing is reflected on the NotePerformer mixer (no channels for the trombones are automatically created).

It’s confusing whether the assignment of sounds to instruments should occur at the Setup or at the Play tabs… they seem to deal with the same stuff. However, the issue is not fixed in any of them.

Honestly, this is too cumbersome and discouraging. And the integration of NotePerformer with Dorico seems to be very flaky.

Typically NotePerformer sorts this stuff out automatically. You add instruments in Setup mode and Noteperformer correctly identifies them.
My suspicion is that there’s something dodgy with your MIDI file.
What happens if you select the (original) Bassoon instrument in Setup mode, right-Click and go Edit Names…? At the top of the dialog that appears, what is the (greyed out) instrument name?

Ok, I did that, thank you. Yes, now it “read” the bassoon and trombones. However, now I have to change all the instruments that NP had miss-identified: oboe to EH, flute to viole, flute to contrabass… the score says “VIOLE” and yet a flute patch is assigned. If every time I add a new staff or instrument I have to “reboot” the playback template for it to recognize them, and then I have to fix, every time, the wrong instrument assignments… this is obviously not useful.

What is the (greyed out) instrument name? Bassoon, actually.

I can only stress that what you’re seeing is highly unusual. This is not normal Dorico/NotePerformer behaviour.

I would not know. I downloaded the 30-day trial two days ago and I’m trying to work with it. I composed on DP, exported a midi file, imported it into Dorico 2 (I did the same thing in Sibelius to compare and Dorico was much more elegant with the way it imported it), but then I had all these problems with the playback and assigning sounds.

Importing midi files to a notation program is something common in my workflow, so if that’s the issue, I find it a problem hard to overcome. In any case, the whole design and Setup/Play thing to deal with sounds is confusing and it feels duplicated somehow. Maybe it’s just me.

You have been very helpful, thanks a lot.

BTW, Dorico has crashed at least 4 times in these two days…

Again, this is unusual. Hopefully someone from the team will reach out to you tomorrow.

Ah… now you have said the “M-word”, that opens up a several new cans of worms that might be causing the problems!

If you can make a .zip file containing your Dorico file and the MIDI file you imported and post it here, that would be a big help figuring out what is wrong.

I would guess Dorico made a mess of assigning your the channels in the MIDI file to instruments (for example it decided channel 10 was percussion, as per the General Midi standard, but it was supposed to be a bassoon), you then did the wrong things to fix it up, and ended up in a state where “nothing works.”

There usually is a straightforward way of getting it to work, but it we don’t know what was in the original MIDI file we are guessing.