Note playback only on click, not on input

I don’t think there’s much hope, but I’m still asking:


In my workflow, note input and note selection are two very different things:

If the option is checked, when I input a note, it will always play twice: Once when I press it on the MIDI keyboard and again after I entered the length. This is annoying which made me turn this option off.

However, with this option off, I cannot just click a note anymore to hear its pitch. Also, when changing the note up and down, it is no longer played.

Is there a way to workaround for this? No repetition of notes during input but still play them on click?

Perhaps try switching off MIDI thru, if your keyboard itself has sound?