Note Spacing with Polymeter


When I use polymeter in Dorico, I sometimes find that note spacing doesn’t work properly. See the attached screenshots. Has anyone else experienced this, or found a workaround? Or am I doing something incorrectly?

Thank you!

Dear Julian,

Dorico tries to put every homorhytmic note on the same vertical line, but due to barlines that do not match in this context or to accidentals, it really looks weird in that rendering. Have you tried bigger values in Layout options > Note spacing? I guess you could aldo increase the space size, but I assume you already chose the value that fits your needs…
Of course you can tweak things in Engrave mode, with the horizontal spacing tool, but I can understand you try to find a more global solution!

I’m really looking for both — a global solution that would fix this issue, without increasing spacing in the other 99% of the piece. I guess Dorico should automatically add more space around the barlines to account for this?

In Layout Options > Note Spacing, is “Use optical spacing for beams between staves” ticked? If so, try unticking it. I’ve found that while it works beautifully in solo piano music it doesn’t always work well in ensemble music.

Excellent — that fixed it. Thank you!

Oh good! I think when that option’s ticked Dorico bases all of its spacing choices on cross-staffed notes (wherever there are cross-staffed notes). Makes perfect sense in solo music (or indeed in part layouts) but none whatsoever in ensemble scores.