NotePerformer 3.3.2 Apple Silicon (beta) version now available

I just posted relatively recently about bad pops using native NP on M1 Max at all sample rates and buffer sizes:: Audio pops in Dorico Playback

Activating ASIO Guard completely fixed the problem for me.

@Wallander Thank you so much for the Apple Silicon beta! I hear a strange sound effect as if a part of the release of each note is not played back. This was not there before 3.3.2. It’s both with and without Rosetta, with and without ASIOGuard, and both realtime and in audio exported audio, on Dorico 4.3 and MacOS 12.5. I use NotePerformer with 0 reverb and less vibrato, see the attached project and mp3 audio rendering. Could you have a look at what goes wrong?

(edit: buffer size is 1024, and it’s an M1 pro machine)

Screenshot 2022-11-20 at 16.00.49

dorico: minimal example.dorico (594.6 KB)


I am curious, how do you lessen the vibrato in this version?

With Midi cc messages: cc105 is vibrato and cc106 vibrato speed. I use these values on init:

1 Like

I wonder if this relates to the new staccato option in Playback Options.

The Apple Silicon version has been updated, with a fix for Live MIDI recording not working.

@maartenterhorst I also think the audio glitch problem should be resolved.

Re-downloading NotePerformer provides the latest version. We’re not updating official version numbers because it’s just a semi-official Apple Silicon build with identical functionality, and we’re only fixing the discrepancies to the original release. If you run into any issues, please report back as soon as possible. :slight_smile:


I’m impressed with the speed with which you fixed it! It works great.

Nice to be able to use Dorico and NP on full native speed now. Thanks!

1 Like

With this latest release on an intel mac (iMac Pro, i7, 65gig ram), the unisons and octaves of the piano sample are out of tune/distorted. See attached project.
OutOfTuneUnisons_NotePerformer(11222022-intel).dorico (615.7 KB)

If you’re on Intel, then you don’t need to use the latest build.

I had the earlier beta intel version Wallander released that didn’t exhibit this problem. Wondering if it carries over onto Silicon macs. In any case, octaves and unisons should be in tune.

Looking at the score, the out-of-tune passages are two unison piano notes being played on different MIDI channels since “Independent Voice Playback” is activated. This is analogous to having two different pianos, so there may be phasing/chorusing between them. Unless I’m mistaken, this was always the case with NotePerformer. If you deactivate “Independent Voice Playback,” the two notes will be sent to the same MIDI channel. Since a piano can only play a note once, NotePerformer will ignore one of them.

In the case of the piano, I would suggest never using “Independent Voice Playback.” There is no need to because the dynamic is velocity-controlled, and may be adjusted on a per-note level without that feature.

1 Like

Yes the phasing between unisons has always been there.

Thanks. I thought that it was necessary to have independent voices to avoid conditions where articulations (like staccato) interfered with sustained notes. I just tested it and that doesn’t appear to be the case.

1 Like

Hi Arne, I think I run into another problem with the new Apple Silicon NP 3.3.2 version. Tremolo sounds weird, as if the volume and timing of all notes are randomized far too much. Please see the attached audio, image and dorico file again.

edit: yes, I checked it and I have audio exports of the earlier 3.3.2 version that had much better tremolo sound.

minimal example tremolo.dorico (552.9 KB)

Hmm… I don’t recall it sounding any different from this, but I will investigate.

Since we don’t feature solo string tremolo samples, it always sounded rather poor. Especially in isolation and with the reverb turned off.

To rule another problem out, please make sure you’ve increased the tremolo speed in Dorico, as described in this support article:

Thank you. Here you can hear the difference for the exact same fragment:



Thank you! That’s very helpful. I managed to reproduce this issue now.

It will be fixed for NP4.


Great, thank you!

NP4? Have I heard NP4? :star_struck:

See my post here: