NotePerformer and libraries

Hi guys, someone posted this on the FB page. I have the exact same problem, but using Iconica Sketch and not Cinesamples. No respond there, so I’m trying here :slight_smile:


Hi I’m wondering if anyone has an ideas on how to solve a problem I’m having with NotePerformer working in tandem with NotePerformer Playback Engines?

I’m using Cinesamples right now and have all the samples loaded in NotePerformer Playback Engine, but for whatever reason only the woodwinds and glockenspiel are actually playing back. The horns and strings are all silent, but I can see on NotePerformer slider thing, the notes are getting triggered. There’s just no sound coming out of some of them, but oddly enough when I solo one of the violins for a moment only to unmute it, for a brief second the whole orchestra produces sound before those channels fall silent again.

It’s really strange and I couldn’t begin to guess what the problem is!

@Hi @fblockx can you post a short example (Dorico file) that shows the issue?

Okay, stupid example joined. When I play this either with the default HSO, Halion etc template or the regular NotePerformer template, no problem. When I load a library into NP (in my case Iconica), only the bass trombone and the cymbals (go figure) play. When muting and unmuting everything works for about one second.

When loading the library into NP I do get an error message (screenshot attached).


Test.dorico (1.6 MB)

your project works fine here with NPPE Iconica so it looks like some library components are missing – check your Halion and Iconica installations.

Hi @fblockx i can confirm that on my system all looks (and sounds) ok. Sorry that I cannot help more…

I already reinstalled the lot, no change…
Thanks for trying, guys!

It looks it is trying to use components from Halion Symphonic Orchestra, and you only have Halion Sonic. Try a different template?

@fblockx, can you do Help > Create Diagnostic Report and attach the resulting zip file here? This should give us a clue which of the expected content sets is not detected on your system.

Daniel — here it is (away from PC for a few days).
Thanks for looking into this, I’m curious about the issue!

Dorico (521.6 KB)

On the face of it, Dorico thinks everything is available – but Dorico is only checking the presets, and not looking for the samples themselves. Can you run Steinberg Library Manager and see if any errors or warnings show up there?

Here you go. Seems to be all there. No messages whatsoever.
I suspect that the error is on the NP side, but no clue (reinstalled the lot, ect.).
(Thanks again for the effort!)

And when you use the built-in Dorico playback template called Iconica Sketch, HSO, HALion Sonic Sel., Olympus, GASE instead of using NotePerformer, that also works as expected with no errors?

Indeed. This gives no problem at all, and also the ‘regular’ NP works just fine.
It’s just NP + a library…

NPPE only works with fast SSD discs. Make sure IS is on, or move it to, such a drive…

If it’s the NotePerformer Playback Engine for Iconica Sketch, I’m loathe to suggest it, since I know the team at Wallander are generously providing that playback engine free of charge to Dorico users, but I don’t know what might be causing that error if the sounds are loading OK in Dorico directly, so I suggest you open a ticket with them and ask if they have any further ideas.

Will do, and I’ll report back here if any interesting insights follow…

Everything is on the same disk (internal SSD of M2 Mac Mini).

Have you tried deactivating the NPPE engine for IS and redownload it?

As advised by the Wallander helpdesk, that’s what I just did and now it works!