Noteperformer no sound

How do I get sound from NotePerformer 3 in Dorico 2?

I have a string quartet and it worked with the Halion plugin. I changed my VST instrument from Halion to NotePerformer in the Play tab. When I click on the ‘e’ next to it, I see an empty blue screen with the NotePerformer 3 logo and 2 knobs for volume and reverb.

When I click on notes in the Play tab, I hear a trumpet instead of a violin. When I start playback, I hear nothing.

Thank you in advance!

Instead of changing the VST, try using Play > Playback template > Noteperformer. This should set things up automatically.

Thank you for your very fast response! This worked.

As feedback to the makers, I could add that, from a UX perspective, I consider it counter-intuitive that the most obvious way to change the playback instrument is not the one I should use.

I think you can do it that way as well, but then you have to do all the assignments manually, including setting the proper expression maps.

NotePerformer isn’t just a regular VST. It has to know which patch to use for each instrument and how to render all the playing techniques. Just changing the device isn’t enough for NotePerformer to know how to play it. Playback Templates are the mechanism by which this is done. I believe there’s an update to the documentation due shortly where Play Mode has been more extensively documented.

To get NotePerformer 3 up and running in Dorico, I strongly recommend following our Quickstart guide for Dorico:

https://noteperformer.com/?page=support_dorico

:slight_smile:

sorry to jump onto this thread, NotePerformer does not seem to make a sound in my setup…
I apply the Playback template:

no sound…

on the right under VST Instruments NotePerformer does not show up at all:

How can I solve this?
VST Instruments.png
Playback template.png

What a difference NotePerformer makes, Arne! Great work on bringing NoterPerformer to Dorico! For me, it make a huge improvement in my workflow.

-T

Thank you for answering Wallander, but I have followed these steps and I don’t get any playback or sound at all.
The Quick Start Guide says „Opening the NotePerformer interface from Dorico reveals our own high-resolution mixer.“. I am not able to open the NotePerformer interface from Dorico. If I in Play Mode click onto the little e nothing happens. Any further help appreciated.

It doesn’t appear to be installed! You may want to try reinstalling, and make sure the installer is about 690 MB in size in case it’s a damaged download.

Arne, thank you for replying. My installer has the size of 692,7 MB - so I guess it is complete…
I have already reinstalled NotePerformer (trial) twice.
I will find the installation files in MacintoshHD>Library>Application Support>NotePerformer (=not in the user Library). This folder is only 9,7 MB though. Where are the other files located?
I have also restarted my computer in case that made a difference… it does not :frowning:

[success] I have now run the uninstaller command and reinstalled a third time :slight_smile:
This time I was successful and the software is working.

I have the same issue. I’ve downloaded it and it’s showing up in Sibelius, but not as a plug in in Dorico.

Something to do with the whiteboard?

Great! :slight_smile:

FOR REFERENCE:

The actual NotePerformer plug-in is

/Library/Audio/Plug-Ins/VST/NotePerformer.vst

and that bundle contains the entire plug-in and all the data. Make sure that file is there. It should be all needed to have it show up in Dorico 2.

I’m not quite sure how to troubleshoot errors with plug-ins not showing in Dorico. There shouldn’t even be any issues with blacklisting, because the NP3 installer is supposed to handle that for you if it occurs.

First, check the folder:

/Users/your name/Library/Preferences/VstAudioEngine2/

and make sure that the “Vst2xPlugin Infos VSTAudioEngine2.xml” file has an entry for NotePerformer, and that “Vst2xPlugin Blacklist VSTAudioEngine2.xml” does not.

Another thing to check would be if there’s an issue with incorrect user read-rights in the /VST folder. The best way to try this is if you have another VST2 plug-in to whitelist, only to see if that one works in Dorico, or if it’s isolated to NotePerformer.

Did any of you have the NotePerformer 2 plug-in installed prior to NotePerformer 3?

Hi Arne,

Yes, I had NotePerformer 2 installed and working with Sibelius.

It’s showed up on the User…/Vst2xPlugin Blacklist VSTAudioEngine2.xml I’ve deleted the entry but it’s still not appearing in Dorico 2. I’ve reinstalled, reloaded etc. but despite the fact it’s not on the blacklist there’s still no sign of it. Maybe there’s another blacklist?

Hmm… I’m not quite sure, to be honest. If you’ve been running Dorico 1, there’s the blacklist in the regular VstAudioEngine/ folder, but I don’t know if it’s processed by Dorico 2. I think Paul or someone else at Steinberg may know more about that.

Does the blacklist file re-appear with the NotePerformer entry when you restart Dorico 2?

Could you please try restarting your computer, install NotePerformer with no programs running (just install on top of what you have) and see if it helps?

By the way, may I ask if your Mac login usernames contains any unusual characters (anything but a-z, A-Z)?

I would suggest removing the VSTAudioEngine2 configuration files, as that will cause the audio engine to rescan the plugins. On Windows this is in

%APPDATA%\Steinberg\VSTAudioEngine2_64

and on mac

~/Library/Preferences/VSTAudioEngine2

Thanks Arne, thanks Paul.

I’ve now got it visible in Play Mode in Dorico. The issue appeared to be that although I deleted the reference to NotePerformer in ~/Library/Preferences/VSTAudioEngine2/VST2PluginBlacklistVSTAudioEngine 2 and saved the file - when I closed down Dorico, the file was being rewritten with the reference to NotePerformer. I actually had the file open in BBedit and saw the lines of text reappear after I shut Dorico down.
So I then edited them out again, opened up Dorico and then NotePerformer was listed among the VST’s in Play Mode. Moral of the story: don’t edit Blacklists while Dorico is open.

Many thanks for your help. I’m delighted that Note Performer is now integrated with Dorico. A big plus for me.