Noteperformer not working in Dorico (but free license version does?)

So I’m not sure if this is the right place to ask this question but here goes.
I’ve been running Dorico 3 student edition on my desktop no problem with Noteperformer trial version. I then had to switch to my laptop which I proceeded to install both and they work fine on my laptop as well. Then I decided to purchase NotePerformer and install it but once I did that it stopped working. I then re-downloaded the trial version and it registered that it exists but now Dorico is silent and doesn’t register any sound. Could anyone help me with this issue?
[Edit] So I re downloaded and installed the trial version of NotePerformer and the playback works and everything, but every time I download my licensed version of NotePerformer it doesn’t work and in the play section it shows up as !NotePerformer!? or whatever.
Not sure if this is a Dorico issue or a NotePerformer issue.


Welcome to the forum, Brett.
On what exact version of Dorico does NotePerformer not work?
Also, please do ‘Help > Create Diagnostics Report’ and post the corresponding zip file here.
From there I can give further advice.

Hello Ulf

I tried clicking Help>Create Diagnostics Report but nothing came up.
I’m using the most recent version: Dorico Pro 3.1.10

We are currently 3.5(.12, I think). Try updating dorico first. Also, the diagnostic file appears zipped on the desktop.

Don’t I have to purchase 3.5 edition? Also I’m not sure how that will help my situation.
Ok I’ll look for the zip file in my folders

Dorico (327.1 KB)

My apologies. I forgot that 3.5 was a paid upgrade. Many new features were added and many bugs were squashed, so it was worth it. That said, at this point you might as well just wait for version 4.

IS the problem occurring in new projects and existing documents?

It’s possible that Dorico considers the trial of NP to be different from the purchased version, and so documents are looking for the now “missing” trial. In which case, you just need to re-apply the Palyback Template for existing documents, and make sure that NP is set as the default template in application prefs.

(I’m sure Ulf will come back with the correct diagnosis…!)

Hi Brett, please stop Dorico and delete the file C:/Users/Pixel Fox/AppData/Roaming/Steinberg/VSTAudioEngine3_64/Vst2xPlugin Blacklist VSTAudioEngine3.xml
Then restart and see if NotePerformer still gets blacklisted.
If it does, please send me mail to ‘u dot stoermer at steinberg dot de’ and I give you further instructions.

I made a video describing my issue but I didn’t know I can’t send links.

I’ve tried uninstalling and re-installing both Dorico and my paid version of Noteperformer. This issue happens with new projects and existing projects.

Brett, you can send your video to Ulf via email at u dot stoermer at steinberg dot de, as he suggested above.

Issue has been solved. Thank you

I’ve sent Brett the fix components from Dorico 3.5 and with those it does work now with him.