Noteperformer stuck on startup screen, not loading

Hello all,

I’m running the latest versions of Dorico 3.5 and noteperformer 3 on a new 2021 MacBook Pro M1 pro running Monterey.

When opening any project, and independently of whether noteperformer is the default playback template or not, it gets stuck on this screen (screenshot bellow). No sounds are loaded, there is no playback, nothing in the mixer, and the playhead moves.
The strange part is that I think Noteperformer worked fine last week.

I have tried reinstalling Noteperformer and cleaning the audio Engine cache, to no avail.
Some people on the forums talked about deleting a blacklist, but this doesn’t seem to exist anywhere in the new Mac OS, at least not where it is described in the other posts. Everything worked fine on my previous intel MacBook.

Thank you,


PS: Btw, the noteperformer screenshot uses the interface of an older Dorico version, the default playback template option is located elsewhere now. I don’t know why Wallander doesn’t change that…

Please load that project again and then from the menu choose Help > Create Diagnostics Report* and post the corresponding zip file to a reply here. Thanks

Thank your for your reply, Ulf !

Interestingly, now there is a trumpet sound when selecting notes, and still no playback.

Dorico (235.1 KB)


Thanks for the data, but in the logs I can’t find anything unusual.
What if you go to Play mode and then choose from the menu Play > Playback Template, does it then play back?
When you open the NotePerformer window, does the NotePerformer mixer get shown?
And if you press the Play button, does the green line move in Dorico?
Is there any indication of MIDI being received from NotePerformer; have a look at the top left corner of the NotePerformer window. There is a “red LED” that shall flash whenever it receives a MIDI note. Does that happen with you?

Reset instrument names…?


When I choose NotePerformer from the playback template menu, still no sound. The startup screen appears (screenshot above), but the mixer never gets shown.
The playback head and green line does move in Dorico when pressing play.
The red Led is not flashing in NotePerformer either.

The project makes 0 sound again, not even trumpets, let me send you the diagnostics:
Dorico (356.6 KB)

And the project file just in case:
Prelude and Fugue in C minor.dorico (530.3 KB)

Thank you !

fratveno, there is a reset button at the top left corner of the NotePerformer window, but all it does is bring the animation of the startup screen again. As I can’t access the noteperformer mixer, there is no real way to actually to reset the instruments, as there aren’t any loaded to begin with…

When I opened your file, I too got the NP Splashscreen. However, as soon as I reapplied the NP Playback Template, it worked perfectly. This was repeatable.

I re-saved the file in working condition and it now opens normally.
Prelude and Fugue in C minor-edit.dorico (530.6 KB)
Does this now work for you??
Do other files using NP work, or is it just this one?

I suspect the splashscreen appears when NP cannot find a suitable playback template (eg. if you change a VST instrument to NP without applying the template… you will reach the scplashscreen)

1 Like

Yes, I seem to remember that the brass sounds indicate that NP can’t identify the instruments… so what I had in mind was Setup/Reset instrument Names… then reapply the PT

[EDIT - I just opened the file in 4.0.1 and it played and behaved completely normally…]

To me it seems that NotePerformer can’t find the template files and accordingly does not load any sounds. I’d strongly recommend reinstalling NotePerformer.

I have reinstalled NotePerformer yet again, but no difference.
I have opened Janus’ edited file, but I have the same problem; stuck on splashscreen, no sound, even after reapplying the playback template. Same for other files. Sometimes the NP mixer loads, but no sound, and when reseting the instruments, it’s back to the splashscreen again.

The worst part is that this very project worked perfectly a few hours ago.

Would upgrading to Dorico 4.0 solve this issue…?

You aren’t by any chance renting-to-buy NP by the month, are you?

It was a one time purchase!

It shall work equally well on Dorico 3.5 and Dorico 4, but I think that some file is missing somewhere from the templates. I have to find out what files need to be where for the templates.

Okay, just a thought since we are at the start of a new month.
Grasping at straws.

I see, thank you for your input :slight_smile:

@simon_precheur , in the folder /Library/Application Support/Steinberg you should have a ‘Dorico 3.5’ folder, and within that ‘PlaybackTemplateGenerators’ and ‘PluginPresetLibraries’. What files are in those folders with you?

What’s your sample rate? NP only works with 44.1 …

Ulf: For me, each of these folders contain a noteperformer folder, with the following files:

PlaybackTemplateGenerators :

PluginPresetLibraries :

fratveno: In this case I am using my computer’s built-in sound card. For what it’s worth, the “audio midi setup” app on my Mac is set at 44.1 kHz.

If none of this gives answer, should I also try reinstalling Dorico?

Thank you so much for your help everyone!!

Hi @simon_precheur , thanks for the data. To me this all looks normal.
To be honest, I’m starting to running out of steam.
What if you start with a new project from scratch, does NotePerformer behave the same way?
And also, have you been to the NotePerformer forum or Wallander’s support?
I see no wrong doing from Dorico side, so I doubt that reinstalling Dorico would make a difference, though of course you could try.