Noteperformer4 Block-listed in Dorico 5

I recently set up a Mac Studio M2 Ultra. Dorico crashes quite often, but also Noteperformer 4 has been block-listed. Hopefully, the attached diagnostics file will help shed some light on what is going on.
Dorico (1.1 MB)

macOS 13.5, Dorico 5.0.20, Noteperformer 4.1

The blacklist does not tell why it got listed, so please run the attached shell script and post the corresponding output to reply here. Please don’t hesitate to ask if you need more detailed instructions.
Thanks (846 Bytes)

Hi Ulf,

I tried to run the shell script through the terminal app, but maybe I’m doing something wrong since there isn’t a file being generated. The message in the Terminal says “Scanning all VST2/3 plug-ins…” but nothing appears to happen after that.

Okay, and what is the output in the Terminal if you copy and paste the following line?

/Applications/Dorico\ -p /Library/Audio/Plug-ins/VST3/NotePerformer.vst3

I am not at my Mac at the moment, so the given paths are just out of my head. Please check and correct if necessary.

Here is what appeared in the Terminal:

Thanks. That looks totally normal and as expected. Could you please go to the Dorico Preferences dialog and on the Play tab you somewhere find the button Clear Audio Engine Cache. If you click that and restart Dorico, does it still put NotePerformer on the blacklist?

Unfortunately, Noteperformer 4 is still Block-listed after clearing the audio engine cache.

I’m currently on the road and will come back to you latest by Monday.

Hi @ctpeck , sorry for the delay.
So could you please run that command in the Terminal window once more, but additionally - after that command ran - type in the following line and hit the return key:

echo $?

A number shall appear, please tell me that number.

After running the command in the Terminal, a different message appeared this time.

139 appears after adding the second command.


Hi @ctpeck, it is a myster to me, why on the second time the output is completely different. Did you do something with NP or have an explanation for it. At the moment I have no better advice than reinstalling NP and trying again

I wish I had an explanation for the different output in the Terminal, but I haven’t changed anything on my system since I first posted about this. I haven’t installed any new updates for anything. The next thing I was going to try is to uninstall/reinstall both Dorico and Noteperformer and see what happens. Maybe reinstalling Dorico will also help with the frequent crashes that occur when I launch it.

Thanks for trying to help, Ulf.

With the second output it is no wonder that NP gets blocked, so yeah, try a reinstallation of both.
If you still have crashes with Dorico then, please send a new Dorico Diagnostics Report.
Your case is really most peculiar.

I uninstalled/reinstalled both Dorico and Noteperformer. I did get a crash upon the first launch so I attached the Diagnostic. The crash report looked the same as previous crashes.

The good news is that Noteperformer wasn’t Block-listed, but I’ll see what happens after some more testing.
Dorico (792.5 KB)

Any news @ctpeck ?

The crash is actually in Dorico itself and not in the VSTAudioEngine process, so therefore I am pretty sure it has nothing to do with NotePerformer.
But @dspreadbury , please do have a look at the Dorico crash file. Thanks

Once Dorico is open, I am able to load projects and create new ones using Noteperformer. However, Dorico has been hanging when I try to quit, so I end up having to force quit. I attached a zip file that contains a Sample and Spin dump from the Activity Monitor just in case they might be helpful.

Dorico (413.1 KB)

@Ulf, the crash here is one we’ve seen before, when Dorico is trying to retrieve the summary state from the audio engine client, presumably because the audio engine itself either never started running, or has crashed.

The spindump shows that the VSTAudioEngine’s main thread is blocked waiting for one of the realtime threads. But at that time there is no more NotePerformer loaded into memory.
@ctpeck , does this now happen everytime you are running Dorico?

I used Dorico on and off today and I wasn’t getting the hanging while trying to quit. Today Dorico would just crash as soon as I tried to quit. I found that this only happens when Noteperformer is being used. If I use one of the HALion playback templates instead, Dorico closes without any issue. :exploding_head:

Could you please send a new diagnostics report?
Thank you very much.