Notes behind slashes do not transpose


I have a problem with transposing (using the transpose dialog in the write menu) when notes are behind slashes. Assume I have a piano accompaniment like this:

I now want to hide the accompaniment behind slashes from the second occurrence on. The accompaniment would still play back correctly. If I transpose now the whole thing from D minor to C minor, at first sight, everything looks nice. Revealing what is behind the slashes shows that these notes have not been transposed (still the original Gmi7) and play back the way they were originally.

I don’t believe that this is an intended behaviour?

Heinz —

1 Like

The music won’t transpose because it’s not selected. It’s perhaps not completely intended behaviour, but it’s a consequence of the way the program works: editing operations will only take effect on items that are actually selected, and when the music is suppressed by the slash regions, it can’t be selected, and therefore it can’t be transposed.

Thanks for this quick answer, Daniel. I understand the problem. May be you find a way to change this. I sometimes happen to need to transpose an existing full score (20 instruments), e.g. when changing from a male singer to a female singer which usually means transposing the score by a triad.

Yes, I can certainly understand that having to remove the slash regions in order to transpose the music is less than ideal.

Adding an appropriate filtering option in a future release, perhaps?