Notes being played back exaggeratedly short in Note Performer

I’ll send you through the musicXML so you can see the difference between S and D. But it sounds like (from Dan’s comment above) that it’s an end note offset issue rather than NP.

I finally had time to try both Arne’s method (above) and Dan’s. Arne’s gives me the playback result I would expect by default in my jazz-oriented score (not sure if Dan’s suggestion was also designed to address the issue of notes playing back too short by default, but it didn’t seem to affect things noticably, regardless of what values I used - not sure why). I do wish, though, that there was some way I could achieve Arne’s result without having to manually insert a value of “1” to CC 108 for every part in my score in order to get it to play back everything as I would expect. Any chance this could be more “automated” for Dorico in the future (and made more the default?) Without this (as I mentioned), my score consistently plays back everything much too short when I use the defaults Arne recommends for Dorico setup (I’m on a Mac, if this makes a difference).

Thanks and best -

  • D.D.

It would be very cool to have a jazz/swing interpretation mode in Noteperformer. That would be mainly tenuto 8th notes with gentle accents on 8th note off-beats and shortend quarter notes on downbeats by default.

Yes, this is something that has been on our list for a while - the ability to specify the default note playback % in the expression map. We hope to address it soon.

That would be excellent. Arne’s Note Performer is so close to being quite useful for more jazz-oriented playback but being able to have the default timings more accurate in Dorico without unnecessary tweaking would be fantastic (and Arne: I’m still also hoping for a NotePerformer “Jazz Big Band” edition :slight_smile: - it would be hugely popular, I suspect, for especially jazz education!)

  • D.D.

I’m just wondering if there has been any progress on this. I have the latest version of Note Performer and Dorico and I’m noticing that Arne’s previous suggestion of inserting CC108 and invoking “permanent tenuto mode” for every big band instrument to make the playback less exaggeratedly “staccato” by default in a jazz context is no longer working for some reason. I previously was also able to do this by using “Draw” and just clicking in the controller lane in Play Mode for each instrument once at the beginning such that the value was “1” and it seemed to draw a line for the entire session. Now I need to use the “Line” tool instead. Either way, it doesn’t seem to have the same effect on the output that it previously did (again: smoothing out the exaggeratedly short playback, at least in a jazz context), so I’m trying to find another solution and welcome any suggestions.

  • D.D.

No, this hasn’t yet been done, but it’s still something we are planning to do.

There’s also no reason why data entered for CC108 would not be output during playback, so perhaps you could cook up a simple project (one instrument, a few bars) and send it to Arne for his advice.

Yes. You can select all—Notes in a section and set the values in one shot.

Actually, if you select them using the normal mouse click it hides the properties after the second click. If you select the notes only (not dynamics or other items) using the control-click method, then you can select them and change the properties in one go.

Windows 10 Pro
AMD 4 ghz 8 core

I think I discovered something.

The issue seems to be ties and articulation marks. If I have two notes tied together (say, across a barline) and the leftmost one has an accent, everything is fine until the barline is crossed. If I remove the tie (or remove the accent) all plays normally.

I don’t think so. Select everything in a range, then filter-select only Notes and Chords. You should see playback offset properties in the bottom panel.

Dan, you’re right. I didn’t think of filtering. That sounds better.


Is this issue addressed in Dorico 3.5? If so, just for this particular feature, I’m going to purchase 3.5 upgrade asap.


Yes, this is included in Dorico 3.5.

Yay! Thanks Daniel. :grinning::+1:

I just got this reply from Arne (Wallander Instruments) for Note Performer regarding note playback duration adjustment :confused::

You can’t override the note length from the expression map. That won’t work, unfortunately.
May I ask if you’re using the latest version of NotePerformer? Or
whether you updated NotePerformer at the same time as you updated Dorico? There are recent versions of NotePerformer where the CC108 feature didn’t work as expected.

Best regards,

I wish Arne could be part of this conversation in this forum to make his replies more accessible for everyone.

Arne may not be completely up to speed with the changes we’ve been making in Dorico. Although we do communicate our plans to him ahead of release, due to the current global pandemic he indicated to us that he was not actively working on a new NotePerformer update to take advantage of any of the changes we’ve made in Dorico 3.5. When he’s ready to get back on board, he’ll find lots of new goodies that he can use to improve the expression map for NotePerformer, including insulating NotePerformer from us changing Dorico’s default playback options.

So you can change the note length from the expression map in Dorico 3.5, on a per-switch basis. Whether or not Arne chooses to make use of this in future is up to him, of course.

Thanks Daniel for the clarification! :pray:t4:

After resisting NP for a long time, I finally bought it. The playback problem just came up…great workaround Dan…thanx

Hi, I’m having this issue suddenly on a new score today. I’ve manged to track the change to a single staccato. When I leave it in (as per picture) it cause a held notes 40 or so bars later to play stacc. If I take the stacc out the held notes are fine. How do I fix this? Cheers.
Screenshot 2024-02-13 at 4.04.10 pm

Perhaps you could append the project as it’s hard to work out much just from the screenshot? Is it related to the “maximum duration for staccato playback” option which has come up a few times.

1 Like