Notes hanging in CB11, randomly

For quite some time now notes have been hanging when played although the keys have been off. It happens in random fashion, say, every fifth-six one. Impossible to play or work. It seems like, every now and then, there is no note-off (or Volume=0) message transferred to, or receive by CB11. On CB forum I’ve found old posts from 2015 which mentioned old Cubase/Yamaha CMC 113 drivers as a solution. I suppose new CB11 Pro includes all that, or does it? I have my keyboard (iCon Nano 88) connected via MIDI cable to Steinberg ur22 mk2 MIDI input. My hard/soft/ware is pretty new, bought in 2021.

I’m stuck. Many thanks for any suggestions!

My PC: Win10 Ent 64x, Intel i7 10700, ASUS ROG STRIX Z490-G, Corsair Vengeance 32GB (2x16GB) 3000MHz, Samsung EVO 1TB SSD, HGST/WD 8TB HD.

Have you tried changing the midi cable? The pc is fine (very similar to mine) and it does sound like a problem with messages not getting through occasionally


I would try to connect your MIDI keyboard via USB directly to the computer.

Hi guys, I’ve tried MIDI cable first, negative. (It would be strange to have such a consistent, although random, malfunction from faulty cable.) But then USB cable does it. But, I think it is not because of cable connection but because of software. I think it is more proper to say, keyboard’s MIDI software, transmitted via USB cable, does it. (Keyboard: iCON iKeyboard 8Nano.) It has useful advantages of controlling the controlers (…), of course, but what bothers me here is this: how come that such a basic thing like note off (or note vel=0) all of the sudden doesn’t work properly. It works flawlessly on first Cubase on Atari 30 years ago, and ever since. Is it a sign of a instability of MIDI functioning? Or symptom which may be present also in USB setup but to much lesser degree. I’ll ask Cubase support that, in case no one notices this post. Anyway, thanks guys for help and good will!

Is this happening on Cubase 11?

Have you tried to load an older version of Cubase and check to see if the problem shows there too?

Yes. It began slowly, say, a year ago, on my old gear, which was all different from what’s on the list above. So, it started in Cubase 5, with Roland A30 master keyboard, Win10 64x, PC 10 years old (Intel i5…). Interesting…

I see,

So, your MIDI keyboard was different than the one you are using now?

Are you using a MIDI patch-bay, or going straight into the PC via USB?

Began slowly to all versions of Cubase, up to 11 I take it?


Yes, it was old Roland A30 master keyboard. It was connected via MIDI to PC interface(s) (Steinberg UR22, to name just the last one). And yes, I jumped from C5 to C11 straight. I thought it would go away, I also didn’t work intensely as I’ve just finished my album. Yet, I cannot pinpoint the reason why it starts, but it is interesting all the same as it appears in different configurations.

Hmmm, strange problem, I have never some across this issue. I might be wrong, but it might be the MIDI patch-bays not working correctly. Some bad luck with your patch-bays, misinterpreting the MIDI signal might be taking place here…

I would try (if possible) another MIDI patch bay, if you can, connect directly via USB and see if the problem goes away. Also, have a look on the MIDI options on Cubase, play around with the options.

usually the two clocks (one within Cubase, and one withing the computer) get out of sync. This causes havoc with the performance, especially if the computer is on for many hours, but I have never heard of MIDI notes hanging.

Let me know when you get this fixed if you can, I would love to know what the problem is.

I used MIDI patch-bays within sound card a long time ago and everything was ok. Since then, I always went directly to my PC via Steinberg UR22. But, to be sure, this hanging of the notes didn’t start simultaneously with any changes of the audio gear, which is strange. (First I thought it way my old Roland master keyboard.) Now, after all this time, a year probably, I’m forced to fix it. I googled it a bit in resent days and it seems not to be so an exotic phenomena. (BTW, I did fixed it, as I described it in my previous posts.)

Ah, I missed your post, will check it out, great you sorted it out!

Thanks. I mentioned the solution in my first reply, almost in the beginning of this thread. I changed my MIDI cable connection (from master keyboard via MIDI interface to PC) with USB cable directly to the PC and now it’s OK.

1 Like

Great to hear it!