Notes that linger

Sometimes (VST) notes linger. That is, I stop the music, but one or more notes linger. Until today I could stop this by playing the same note again (same track same note), so I didn’t worry too much, since the problem was easily and quickly fixed. But today that didn’t help anymore. In Violin2 (Iconica), after playing a fast riddle, 3 notes were lingering. After repeating the riddle, one of the two stopped, but two of them continued. So I thought it was time to figure out what the cause of this lingering really is, since I guess I’ll have to close the project and re-open it, to get rid of it. Can anybody help?
Oh yes, it’s not always after playing the keyboard that notes linger, often it’s also when just playing a loop.
And I’m pretty sure that it can’t be because of insufficient processing power: 128RAM, 32 cores, 2CPU’s.

Hi,

Does the MIDI > Reset function help?

Could you try to change your Audio Device’s Buffer Size, please? In these cases, sometimes even decrease the Buffer Size helps.

Thanks for your fast reply, Martin.
I’ll surely try that. But since it’s not always happening, I even don’t know how to provoke it.
Oh well! While I’m writing this, it happened again, and indeed the MIDI>Reset function helped. I have also lowered the Buffer Size in Studio Setup, to achieve a in/output latency of 9.6/11.6msec instead of 16.4/19.4msec. I’m eager to see what will happen in the future. :+1:

Well, at this moment it happens all the time, in that particular phrase, that I’m working on! In fact, working is impossible in this way. In this case the trouble occurs with Trumpets and three Violins, that is in 4 tracks. There are several notes that can linger per track (in one of the Violin tracks, I heard 4 notes). With the MIDI>reset, it stops, but only till the next time that the phrase is played. I again tried if the notes would stop, when I played them on the keyboard and I found out that they - remarkably - all stopped after playing these particular notes exactly three times. Maybe that’s an indication? Anyway, I’m pretty desperate at this point…
I also tried different settings of the Buffer Size in Studio Setup, but it made no difference, as far as I can tell.

Is this happening just with a specific plugin or can you make it happen with the same midi on other plugins?

I’m asking because I’ve experienced plugin specific hung midi notes before.

And if it’s plugin specific, you may want to contact the plugin maker.

Welcome to the illustrious world of hanging notes!

While I am relatively new to Cubase, I have been working with Logic and sample libraries for years. As Martin pointed out, this is often plugin-specific and some sample libraries are prone to that more than others. For example in Logic I could never use the legato patches of Cinebrass. I used only sustains until the end right, before bouncing, then I would switch them to legato where initially desired.

Also - are you using expression maps? While I am working on my Cubase template I notice that sometimes expression maps amplify this behavior as well.
Sad to notice, that this seems to be a big issue in Cubase as well. Especially regarding expression maps I was secretly hoping that they might be more bullet-proof than articulation maps in Logic…

Hi,

Totally agree with this all.

1 Like

Just curious:
If something in a plugin isn’t working in several hosts, what makes you think it’s a host problem rather than a plugin problem?

Short answer: it can be plugin specific but it does not have to be. The issues often pan out differently in each DAW. Still, there will be libraries that seem to have no issues in either one, then there are some that have issues in both, some that may have issues only in one.

It feels that in both cases of Logic and Cubase the articulation switching systems have been implemented more as an afterthought and haven’t yet given enough attention from the developers.

It is cumbersome in Logic, and in Cubase as well. You can’t even edit several articulations at the same time or incrementally increase or decrease a channel number for example by dragging the mouse. Basic stuff that you would expect in a GUI for that. And that’s just the GUI.

In my experience Spitfire Libraries work out pretty well under Logic. Setting up expression maps in Cubase however resulted in a mess (double note triggering). Using UACC instead of keyswitch based maps was a little better but still not always reliable. So far Cinebrass behaves OK with Cubase, but I have not done enough testing as I am still template-building which takes a lot of time.

Hi,

I had this issue with some libraries in the past in Logic, Digital Performer and Pro Tools too. Then the VSTi updates fixed it sometimes for some specific DAW, not for the others, sometimes the updates fixed it for all DAWs.

For me, this was always kind of random.

To all of you, guys. It’s great to have so much respons, all willing to help. At this moment it’s impossible for me to reply exactly on everything that is said. I will first have to try out a lot for that. But the thing is, I’m using Iconica instruments in Cubase Pro 11 - both develloped by Steinberg. I guess both are at the top range of what they are offering.
I assumed both products would work fluently with each other - in fact, I believe they should. My ambition is to make music and certainly not to look for ways to maneuver around bugs. If the problem lies with Iconica and therefore not with Cubase, I should therefore contact the producer of Iconica, instead of Cubase. But in this case it is the same company. Pretty sinister and certainly not hopeful.

Hi,

In this case, I would get in contact with official Steinberg support.

1 Like

Indeed, Martin, I agree. Overall and up till now, I really liked working with Cubase. I know not every plugin works perfectly fluently with any DAW. That’s why I choose Iconica (a Steinberg product) as symphony orchestra, because I wanted to avoid those kinds of problems. Turns out differently so far… I hope the Steinberg Support department can come up with a pretty straight forward solution. If so, I will write it down here.