Notes triggered but not entered in drumset staff with "Use Percussion Map"

Hi All,

I’m new to Dorico after being completely bowled over by the Dorico Pro 2.0 update. After 25 years or so on another product, I can’t imagine ever going back. The power, elegance and depth of Dorico are amazing. It’s so well thought out that I’m really not even concerned about those features I’m currently missing, like string harmonics, because I can tell that they’ll be there in due time and will be really done right.

The current issue I’m having could,as always, just be operator error, but it is this: when I switch Percussion Input to “Use percussion map,” which would be my preferred method of input, I can hear the notes being triggered correctly (I’m using a GM map), but no notes are entered into the staff and the caret does not progress. If I jump to any other instrument the notes enter normally and the caret moves forward as expected.

I’ve tried the normal stuff like restarting Dorico, rebooting the computer, and using a new file, but the result is always the same.

I’m on a late 2013 “trashcan” Mac running OS version 10.13.4.

Any help would be greatly appreciated. Thanks!

That’s really odd, Steve. Are you working on just a regular drum set staff? Is the caret visible and positioned on the staff?

Hi Daniel,

Thanks for the quick reply. It is a regular 5-line drumset staff, and the caret is visible.

In going back in to get the answer to your questions, I realized a mistake I had made. I loaded a drumset, but neglected to load the GM percussion map. So I just did that, and got a partial fix.

In addition to notes playing back, there are now notes being entered in the staff, and the caret is moving as expected. The problem now is that it will only input 1 note at a time. So if I hit the note for a kick or snare or high hat, the sound plays and the correct note is entered. But if I hit kick and high hat together, they both sound, but only the kick drum note is entered in the staff. It’s the same if I play snare and hat together: both sounds play, but only the snare note appears in the staff.

Is there a setting I need to change, or some other procedure that I could be overlooking?

If I remember correctly, I’m afraid that is a limitation of the ‘Use percussion map’ setting: it only works for one note at a time. Sorry about that! This is something that’s still on Paul’s list to improve in future.

If that’s the case it’s certainly not the end of the world. I got the idea that this was already implemented from this video with John Barron from November, which shows him entering drum parts in the manner I was trying to do it. The part in question is at around 19:20. https://www.youtube.com/watch?v=pAfl9RciRO4

Indeed, John seems to manage simultaneous input at about 19:25 of the video, and he is using a percussion map rather than the treble or bass staff input.

See this thread; https://www.steinberg.net/forums/viewtopic.php?t=132958

I’m also still trying to wrap my mind around the extensive percussion-related options (bravo!) Right now, though, all I’m trying to do is set things up such that when I play C(2?) on my MIDI keyboard, it creates a bass drum on the bottom space on the drum staff I’ve set up, etc., etc. (as one might also find playing drum sounds in Logic Pro, etc.). I know it has something to do with choosing “Use Percussion Map” in Preferences, but Steve also mentioned (above) loading a GM percussion map. So my first question is: how do I load a GM percussion map? (presuming this helps). I’ve also tried assigning the drum staff in Play Mode to Superior Drummer, and also to the default NotePerformer3 drum sound, but in either case I’m not getting the MIDI keyboard notes to correspond to what I want in the staff and am sure I’m doing something (probably simple) wrong. Thanks for any help!

  • D.D.

You have the choice of using the staff position defined in the percussion instrument, relative to either a treble or bass clef, or using the GM percussion map – but of course the GM percussion map is only useful for a GM drum kit. I would guess that Superior Drummer is at least mostly GM-compatible, so it should be the case that you can do the following:

  1. Add a drum set to your project.
  2. In Play mode, assign that track to Superior Drummer.
  3. In the VST Instruments panel, click the cog button for the Endpoint Setup dialog next to the Superior Drummer instrument.
  4. In whichever channel in Superior Drummer you’ve directed the drum set track to in step 2, set the ‘Percussion map’ value to ‘General MIDI percussion’.
  5. In Preferences, set ‘Input onto kit or grid’ to ‘Use percussion map’.

I imagine perhaps the step you’re missing is step 3.

Thanks, Daniel - I’ll try this! Incidentally, a pleasure to see you at yesterday’s NYC-based Dorico 2 presentation event at Yamaha. Exciting things ahead for the program for sure, and I very much appreciate the obvious passion you and the entire development team have towards making it the best-in-class (though judging from your multiple posts here following the event, you must never sleep :slight_smile:!)

  • D.D.