Novation Impulse controller failure..

Now, I know that the Novation Impulse doesn’t have a set of maps for Cubase 8 yet (I suspect it never will - Novation seem to be too busy making grid-style controllers for glorified DJs to concentrate on supporting more traditional controllers), but I’ve never had a big problem with it. My Impulse 49 worked at a fairly basic level straight out of the box - keys all worked, the sliders controlled channels on the Mix Console, and the rotary controllers would cheerfully control parameters in VST Synths like Hypnotic Dance.

Until this week, when, despite me having changed absolutely no part of my setup AT ALL, the sliders no longer affect the Mix Console, and the rotary controllers no longer tweak anything in Cubase.

Is this the gods of technology telling me that the Windows-based PC I built needs to go into a skip and be replaced with a Mac which, when I turn it on, will behave in exactly the same way it was behaving just before I turned it off last?


How did you set your Novation Impulse to control your Cubase MixConsole? Did you use Mackie Control or Generic Remote Device? Make sure, the device you used, has still Novation Impulse as an Inputs selected, in Devices > Device Setup.