Nppe with VSL no sound

Hey all,

It’s been a minute since I had NPPE up and running smoothly. I just recently added some instruments from VSL to cover my wind section. All looks correct and I’m even seeing blinking white signal light when hitting playback. However, I’m getting no sound out of any of the newly added samples.

Can you explain which are the new ones?
Some of the NP channels are soloed and some are muted, therefore it is difficult to understand what your expected behaviour is. Secondly, how does the Dorico mixer look like? Are there channels muted or soloed?

Sure,
Firstly, the (new ones) would be all the instruments highlighted in white, from the Syncron Vienna Symphonic Library. This is how NPPE indicates the connection between it’s player that sits in dock and Doricos internal playback template with NP. Here are some screenshots that I have from the current project. One can see that you look at the NPPE next to the individual instruments, there is a white midi signal indicating connection. However, there isn’t any indication on the individual Fader track within Dorico. I believe this is normal; because NP is using it’s own player for mixing. Does this make sense to anyone? I feel it’s all set up properly but is a no go. Arg… I’m happy to try another way to get this working, however, I want to take advantage of the expression maps assigned to these custom libraries. Ultimately, I’d like to use these samples as my main template.
T




usually re-applying the NotePerformer playback template fixes these sorts of issues.

Are you sure you actually have the requisite VSL libraries? I would imagine so, but just making sure. VSL makes a lot of libraries, so it is possible to get confused. Verify by going into Synchron Player standalone and expand “Synchron Collections” in the preset list on the right.

image

Oh another thing that’s happened to me is my iLok session died and I had to reopen. NPPE appears to load all the samples, but if you open one of the VST’s you’ll see red X’s across all the presets.

Ok,

I’m looking into this. This is a bit confusing because I clicked on the collection and purchased and downloaded the files through NPPE. Was that not the actual files? Perhaps just expression maps?

The Playback Engines for NotePerformer don’t include the sample libraries themselves - it’s assumed that you’ve already separately purchased and installed the libraries they are for. They have big warnings to this effect when you go to buy a specific NotePerformer playback engine. The engine just integrates the sample libraries that you have already purchased and installed into NotePerformer so that it can drive the libraries.

Yes, I realized this at first and made sure my sample destination path was updated since many of my Synchron libraries were on a separate drive. Check, done! Now I also had to make sure all libraries were authorized on ilok. Check, done. I then had to make sure I went to VI website to download specific notation software pertaining to my Mac. Check, Done. Now, My sounds are ready to be loaded and utilized within Dorico. I have decided to skip the NPPE for now and see if I can get the samples to play through a custom Template that involves Synchron Woodwinds, Synchronized Saxes and Noteperformer (which will cover a few instruments not provided in my libraries, for now). At the moment, I have Noteperformer 4 engaged. I tried clicking the add button to add the saxes to my NP template, but it just overwrites it. Puzzling. Should this not be the place where one creates a custom template of combined libraries?


Ok,

Update for the moment. I was able to create a custom PB Template for the moment. Note performer sounds are playing back correctly. The NPPE is also playing correctly. YAY! However, My saxes arent following the synchronized expression mapping. The are being triggered (After I manually added them in thye VST/Midi set up. So, almost there. I just need a way for the mapping to go to the correct location and I don’t see an option in the endpoint configurations. See images attached.


So the problem with your NP+Saxes is that NotePerformer is first in the list of entries. That means that if NotePerformer has saxophones (which it does), it will use NotePerformer for saxophones instead of the Synchronized Saxophones. What it does is it goes through the list of entries in order from top to bottom until it finds the one that matches the instrument in question.

1 Like

So to remedy the analysis done by @mducharme, just swap the order of the entries in your Playback Template (use the little up/down arrows) so your sax (manual) is above the NP (automatic).

2 Likes

Oh wow, ok. Will give it a go.

Thanks very much!

T

Janus,

This indeed worked!! Thank you. So, if I’ve got this correct, make sure which ever library you want to utilize specific sounds from, HAS TO precede any other library that might also include those same instruments/expression maps?

T

1 Like

Yes, that’s correct. As I said, it goes through the entries in order until it finds one that is able to load the instrument in question and then just uses that one, so specifying the order you want is critical.

Since NotePerformer provides almost every instrument you could think of, putting it first in the list essentially ensures that only NotePerformer will be used and nothing else (but in that case, you might as well use the built-in NotePerformer template since it will do the same thing).

Got it! Thanks for your help and clarification.

T

You can also use the instrument and family overrides…