Nuendo 10.3 Constantly crashes and freezes - so disappointed in Steinberg

Since updating to Nuendo 10.3 I’ve had nothing but crashes. Opening up more than 1 plugin at the same time alone triggers a crash. Inserting plugins triggers a crash. Opening up more than 2 modules on Insight 2 causes a crash. Moving my big toe causes a crash. Other than running at it’s most basic function as a DAW in playing, recording and editing audio most things cause a crash with Nuendo for me.

What angers me most is the fact this is a clear issue that runs back to Cubase 10.5 and I haven’t seen a single response from any steinberg staff across ALL the complaints and forum posts. This is clearly a massive issue and steinberg are turning a blind eye to it. This seriously needs fixing, I literally cannot run projects in Nuendo due to the crashes and freezes. The much looked down upon ProTools on the other hand has been my saving grace and been absolutely solid for this entire lockdown period - not one issue.

I’m just begging for some sort of solution or at least acknowledge this widely occurring problem. It’s a joke that a lot of Cubase users have now got a fix of inserting Soundtoys microshift on the control room insert to prevent crashes from inserting/opening plugins. This doesn’t work for me but it sums up how terrible steinberg have been at trying to fix this problem.

OS 10.13.6
Nuendo 10.3
All latest plugin versions
Attempted clean installs etc

Well, it doesn’t really seem to be a Nuendo problem to me. I have 10.3, I run more than 1 instance of Insight 2 (up to three at a time), I don’t have a problem having more than one other plugin open and I don’t crash when I instantiate plugins.

If the trigger of the crash was as simple as you say it is pretty much all of us would have the same problem.

My guess is that if you really want to have the problem solved you’ll need to be a bit more specific. Like what is your exact system configuration. What’s the specific OS build. Specific hardware. Specific plugin versions. Give a simple step-by-step procedure so that we can hopefully reproduce your results…

And so on.

I’ve clearly said -I- am having this issue as well as a lot of other users out there. That’s great for you that it’s running smoothly but it’s not for a lot of people, including myself. A problem like this should categorically not be happening on any DAW what so ever thus my anger.

I’ve stated my OS, nuendo version and don’t know how much clearer ‘latest plugin versions’ can be - they are all up to date to the latest version as of today.

This isn’t particularly a post to ask for solutions as from the hours and hours of research I’ve done there isn’t one. This is more a call for steinberg to recognise this issue and solve it. This is clearly a back end bug that was in cubase 10.5 that’s now come with the nuendo 10.3 update. They had time to fix it before bringing out 10.3 but clearly they haven’t.

A “DAW” is software + hardware though, and if it’s only the software I’d expect a ton of users to have your problem on 10.3. If a bunch of people don’t then the only difference appears to be the hardware (or other software).

I know it’s annoying that people say “Works for me though” but please take that as an encouragement to give more details so that people can find out what the problem is.

But other than “Insight” you haven’t stated what those other plugins are (other than Soundtoys which you say was fixed?). So in order for people to help you - including Steinberg - it’d be good if you could give a step-by-step repro. For example:

  1. Open empty project with stereo out master.
  2. Create one stereo audio track.
  3. Instantiate iZotope Insight on it.
  4. Open the plugin and two modules.

That way anyone could run through what you’re doing and see if it works.

You can also share a project without audio files and see if other people have a problem with your project file.

K… I’m not seeing the bug though… and I’m not sure why you wouldn’t want to try to solve this by getting help.

if this would be a common bug, we would know that

Here’s how fragile the build is for me:

  1. Opened empty project
  2. Created one stereo audio track
  3. Added iZotope Insight 2 to insert
  4. Opened up Spectrogram module within Insight 2
  5. Nuendo Freezes

Or with different plugins

  1. Opened empty project
  2. Created one stereo audio track
  3. Add Fabfilter ProQ to insert strip 1
  4. Add Fabfilter Saturn 2 to insert strip 2 (both plugin editor windows open)
  5. Nuendo Freezes

Fabfilter, Ghz iZotope, Waves are the biggest culprits for causing a freeze or crash. Ironically my most used plugins.

You’ll have to forgive my abruptness but I’ve just had enough of this bug. As I said it’s just unacceptable and incredibly infuriating and the fact that this was an existing issue in cubase 10.5 before the updates from Cubase migrated to Nuendo in 10.3 just rubs salt in the wound.

I’m glad for your collective bubble that none of you have run into this problem. Others have, however.

What kind of Mac are you using?
What was the latest version that worked for you?
Did you reinstalled it? Or did you tried 10.2 on the same machine?
Witch waves Version?


If that’s so, then others have likely had hardware/software conflicts as well. Your frustration’s coming through loud and clear, and I’m sure that many of us, myself included, who are not having the problem–and who may or may not have other hardware/software issues in the past–can empathize. But if you are having these issues, and the vast majority of Nuendo/Cubase users are not (which is a reasonable assumption), then it makes sense that the troubleshooting process that works for that majority might well work for you, as well. This forum is a resource–why not take advantage of it?

As MattiasNYC suggested, a more thorough description of your setup would be a very good place to start. Forum standard is to list your components in your signature. Optimally, we’re here to help. If you want to get working, work with us!



So like I said earlier I can easily run more than two instances of Insight 2. I’m currently running version 2.10 on the system in my sig. In each instance I can run several modules.

A couple of things though;

  • If I instantiate Neutron it seems that the spectrogram has a large impact on my CPU. If I have two instances open at the same time I’m really on the edge. I can’t remember if it’s the same using Insight, but I do remember that different settings do impact CPU load quite significantly. So if I were you I’d take a look at exactly what settings you’re using for that view and any similar view/module (I think it was the “FFT size” and “overlap” that I tweaked)

  • There’s an update pending in my iZotope “Product Portal” for Insight 2. It is to v2.1.1. Release notes state that they “Fixed a crash in Cubase 10.5”. So this tells me there was a problem apparently with Cubase 10.5. Now, since that’s fixed in 2.1.1 and since I don’t see it in 2.10 it seems that either the previous point is correct and/or it’s a problem that’s tied to a Cubase installation (I’m assuming you have Cubase 10.5 still installed on the same computer, if you don’t then ignore tying it to Cubase).

a little story…

I had massive problems since yesterday with my N 10.3 all other programs worked normal

I installed Resolve 16 and the Cubase 10.5 Update and did some changes on the PC hardware some days ago
and I reconfigured Sonarworks Systemwide
and Windows Defender found a CryptoMiner inside Eventides Instant Phaser dll
did a search for Viruses and so on and uninstalled several things like Systemwide, Wireshark

and now my problems are gone
but I didn’t removed the Cubase Update nor Resolve 16 and I still have no idea what was the cause…

Steinbergs lack of response on this from support is indeed frustrating and suggests complicated problems that are system specific and there from hard to nail down it seems.

Perfect example is I set up 10.3 on a new iMac with 4X the RAM, new system - 10.15.6 and all latest updates of Waves, Izotope, Sound Toys, etc. and so far, no crashing with the plugins mentioned as troublesome which proves something messed up is happening on certain systems.

For the money were paying, we should not be beta testing and doing QC, we need to be able to work!

no problem is mentioned… at least I can’t see one

I can understand Steinbergs footdragging in taking ages to respond to customers and it really sulks…although I consider their product, Nuendo to be really great. It doesn’t crash on me, even when I was running a quirky, outdated PC. So I should think that your PC and its fundamentals could be triggers to the issue. Nuendo 10.3 is pretty sensitive to anomalies in system configuration and could crank up when it notices such.

Maybe he was being ironic? I don’t see any problem in there, either.


The list of problems with 10.3 on the system in my sig is too long to mention and has already been mentioned by others so no point in listing them again.
The point is, 10.3 is stable with enough RAM, the right computer and system and latest plugins.
But that really doesn’t help those having problems.

so the entire post is senseless?

I’m so confused… Language barrier?

No comprendo. :question:

Unless this is a study in logical fallacy, maybe…


yeah, that could explain it