Nuendo and Izotope RX7 issue?

I’m editing some VO with long recordings and usually I set some RX plugins: M declick, de crackle etc etc…

After a while the plugins start to slow down nuendo. If I open DOP and select a clip with rx plugs, they first look white, then black, then normal. But the performance slows down if I keep open DOP, so I have to constantly close it.

I’m doubting if this is because RX uses the whole long file to render instead of the clip itself. As I’m rendering only some spots, my rendered files list would be enourmos.

Someone having the same issues? Any solutions other than render in place?
I saw this is not related with the nuendo version. 8 and 10 behave the same here.`

I’m not sure how Nuendo and RX does it but I suppose it’s possible for both programs to keep one file per update regardless of how many times you process it sequentially. In other words if you process different parts of the same file perhaps it just rewrites it.

What I’d do though is keep an eye on any folder involved. So any temporary RX folder if it exists, and certainly the Nuendo project folder. I’d also open up Task Manager and keep an eye on RAM usage. It sounds like perhaps things get loaded into RAM during a transfer and then aren’t released or something similar.

If I remember and find time this weekend I’ll take a look at it.

Thanx Mattias. I’ll give a look.

Apparently, when you use DOP with any plugin (steinberg or not), nuendo makes a copy of the WHOLE file and processes only that portion. So, in my case, if I have 10 mins recording it makes a new version of 10 mins file.

Honesly, I’ve preferred another approach, like coping only the portion ± the boundaries.

I think this explains my rx problem, as I don’t have it with short files… :bulb: :bulb: :bulb:

One file per case of processing or one file per file?

No, I was wrong, sorry.

When you use DOP, it seems nuendo saves only the portion in the edit folder.
But it seems like a “patch” on the whole file. Infact, if you extend the clip in the timeline at the beginning or end, you’ll see the original file after the handling time used in DOP.

I may think RX7 has some issues with so many “patches” in a long file (more or less a 3 to 8 mins recording).
And I’m pretty sure it’s not compuer depending. Me and my Colleague have the same issue and two different computers: I have a Mac and PC partition on a mac mini 2012, he has a beast of pc and hackintosh of 2015. The same issue appears on nuendo 8 and 10, mac and pc.

Do you have any chance to test this?


I found that when editing audiobooks with RX7 plugins, it helps to go to the pool and remove any unused files from it. Also, when I doubled my memory it solved a lot of plugin problems. Another thing I found was re-ordering the Izotope plugins. Switch their order to see if it helps. I’ve only found this problem with Izotope plugins, as awesome as they are. For long recordings and audiobooks, I usually just go over to RX7, do my noise-reduction, declicking, etc. there, and create new files. I then replace them in Nuendo and remove the originals from the pool so I don’t have a large cache file to bog down playback.

In this case you could just use “make all permanent” which woluld have the same effect, doesn’t it?

Yes and no… doing basic NR, declicking and level management in one fell swoop before you get started can be faster saves a lot of fiddling around per file. For an audiobook project I do much as Neil K does-- do a batch processing of the whole project and export them to an “RX” folder in the project audio folder. Before I bring them into the timeline I often first put’em into the pool and batch adjust the filenames (I never know what I’m going to get). I bounce all of my chapters to disk after editing and typically dump the edited files, though for some projects where revisiting after the fact might be part of the picture I’ll make track archives of the unconsolidated chapters for future reference. But when that’s done I wipe all the edited/additionally processed files from the project-- usually in batches of three or four, depending on the left. This keeps Nuendo running snappily.

I’ve been feature requesting better protection against heavily edited, voluminous projects bogging down for a long, long time. I’d love to be able to save my edited, non-consolidated tracks as track versions without it bringing my system to its knees, but it hasn’t happened yet. My computer’s got plenty of juice and scads of RAM; I’ve experienced these issues on both Macs and PCs. It’s probably my most chronic beef with Nuendo. Fixing it would make a very big difference in my audiobook (and general post-production) work. Not such a big deal for my music stuff…


Yep, controlling the amount of media is crucial on large projects, especially with tons of edits lake audiobooks. I always keep my originals if I have to go back in, but deleting just from the pool speeds things up.

Well I wish this was the only problem I had with RX7 and Nuendo, I am getting full Nuendo crashes with RX7 Mouth Declick and Isotope have no idea how to fix it. Only that plug in which is very suspicious of issues with RX7 and Steinberg. Annoying. I had to disable the plugin

I’m on Mac 10.15.7, I’m using Nuendo11 together with the RX 7 advanced suite. Since a few days I’m not been able to use RX suite anymore, Nuendo 11 crashes every time. In the iZotop chat they don’t know how to help me and say that the technicians will contact me via email. But for now no one has contacted me. I am working on a TV show and I cannot go on. What can I do?

First question is what has been changed on your system between RX working and not working.

Secondly, be sure that all of the VST2 versions of RX are removed from your system.


Haaa, that a good question. Who knows…
I installed Sonarworks SoundID which quickly realized it was incompatible. Used it for a few days and then threw it out of the system. Now I’m back to Sonarworks Reference 4 which used to work fine before. Other has not changed. I have not made any updates of any kind. I had bought RX8 Advanced and installed. Since RX 8 Connect doesn’t work with Nuendo I asked iZotop to give me the possibility to use RX 7 advanced which I didn’t have, I had standard RX 7 which always worked very well.
That’s all. But slowly RX 7 started to work worse and worse until it caused continuous Nuendo crashes.
iZotope VST2 are definitely out of my system.

I’m desperate because I’m working on a TV show and RX serves me like water in the desert. Unfortunately I go very slowly with the work. When a project starts to crash then it always does. In that case I export the AFFs of the “corrupted” project, import them into a new template and start the job again. At this point the RX works again for a while. But it is not constant, sometimes I do this operation even two or three times for each TV episode. Can you imagine what a disaster to work like this?